Results 1 to 7 of 7
  1. #1
    Join Date
    Dec 2012
    Location
    nc
    Posts
    4

    outdoor coil frosting

    while performing heat check upon arriving at heat pump the coil was frosted in sections and the distributor lines were frosted upto liquid line port. pressure was lower that normal. again check is in heat mode. charged unit with 2 lbs of 410a. pressures were up but still had some frosting on liquid line. did i not charge enough or could there be other issues such as a restriction in txv or drier?

  2. #2
    Join Date
    Jun 2009
    Location
    Upstate SC
    Posts
    1,439
    What is outdoor temp and humidity?

    Sent from my ERIS using Tapatalk 2

  3. #3
    Join Date
    Nov 2011
    Location
    USA
    Posts
    401
    Quote Originally Posted by magac View Post
    ..did i not charge enough or could there be other issues such as a restriction in txv or drier?
    Yeah...but you got to provide more info than that for anybody to make an educated guess. Both pressures, SH and SC if possible, ID and OD temps.

  4. #4
    Join Date
    Feb 2004
    Location
    Pacific NW
    Posts
    570
    What jd said.

    Mine was frosting quickly this AM as was mid 30s F and 99% humidity (PNW) - them there BTUs gotta come from someplace, if you look at a psychrometric chart for humidity and temp frost may be what should be expected.

    Here in PNW on HPs with a timer on the defrost the entire outdoor coil is often solid frost 1/2" thick before defrost kicks in.

    Your 'frosting on liquid line' could indicate a stuck reversing valve? Never have seen a liquid line with frost in this climate.

  5. #5
    Join Date
    Jul 2010
    Location
    Eastern Kentucky
    Posts
    55
    Build big bon fire around unit and it will keep the thing from freezing to death

  6. #6
    Join Date
    Oct 2005
    Location
    jax fl
    Posts
    84
    with the information provided cant really help ya. Could be installer did not install correctly... Did you check filter or coil (AHU) to see if they were dirty.... Possible txv issue but I doubt it or it would have been iced up badly or completely shut down on you. More info needed when you need help like that or like dgussler says....Build yourself a fire..... Wont get too much help unless you provide info....
    Sir Ace says, Don't hate the breed, just the breeder!

  7. #7
    Join Date
    Jun 2007
    Location
    Round Rock
    Posts
    3,619
    If it's running in heat mode and it's somewhat cold outside. That is generally what a heat pump does when it runs. It's starts icing up the outdoor coil. That is why it has a defrost mode. To melt the ice that accumulates on it while it is running. Now if you have 3 inches of ice on the coil and the fan can't turn anymore because there's so much ice, then you probably have a problem.
    I like DIY'ers. They pay better to fix.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event