Having problems getting new Quadra-Fire Mt Vernon Pellet Stove AE seviced. - Page 16
Page 16 of 17 FirstFirst ... 691011121314151617 LastLast
Results 196 to 208 of 218
  1. #196
    Join Date
    May 2008
    Posts
    5

    Mt Vernon AE insert autoclean cycle

    Can anyone out there shed some light on the amount of times this stove should go through its autoclean cycle? Mine has been doing it about every 3 to four hours. 6 to 8 times in 24 hours is a lot. It also is shutting down to clean even when the temp in the room is 7 to 8 degrees below the set temp. My dad had one and his only does it about 2 times a day. Could something be wrong?

  2. #197
    Join Date
    Jan 2009
    Posts
    3

    Unhappy

    I purchased a Quadra-Fire Classic Bay 1200 in Oct. 2008 when I moved. I had nothing but problems with it. Everything has been replaced in it. Over last weekend, it dumped pellets and filled up the pellet pot. The pellets were overflowing into the ash pan at the bottom. Somehow this all caught on fire and the entire thing was on fire and blackened everything in this stove. I have had a rep from the Fireplace Store in Billings, MT come out and check it out, replace this and that. Finally, I asked for a refund and they won't refund my money. This is a true LEMON pellet stove. The rep even told me last week that they had returned another one due to it being a lemon stove. The ower of the store won't refund my money but replace it with another stove. I don't want another stove due to the fire hazard.

    Does anyone know if there is a lemon law on these to get your money refunded?

    Thank you.

  3. #198
    Join Date
    May 2005
    Location
    Madison, WI
    Posts
    1,078
    Quote Originally Posted by bburton View Post
    I purchased a Quadra-Fire Classic Bay 1200 in Oct. 2008 when I moved. I had nothing but problems with it. Everything has been replaced in it. Over last weekend, it dumped pellets and filled up the pellet pot. The pellets were overflowing into the ash pan at the bottom. Somehow this all caught on fire and the entire thing was on fire and blackened everything in this stove. I have had a rep from the Fireplace Store in Billings, MT come out and check it out, replace this and that. Finally, I asked for a refund and they won't refund my money. This is a true LEMON pellet stove. The rep even told me last week that they had returned another one due to it being a lemon stove. The ower of the store won't refund my money but replace it with another stove. I don't want another stove due to the fire hazard.

    Does anyone know if there is a lemon law on these to get your money refunded?

    Thank you.
    This thread is about a totally different stove than the one you have. Out of all the quad pellet stove in production right now the CB1200 has been around the longest. It could be considered one of the most reliable stoves in the industry.

    FYI the pellets cannot "overflow into the ashpan" unless the firepot floor is left open since that is the only connection between the firebox and the ashpan. Unless one of the side cleanout traps was left open by mistake. Typically a pot overflow is caused by too much ash / clinkers in the pot that are not cleaned out over time.

  4. #199
    hearthman's Avatar
    hearthman is offline AOP Committee/Professional Member*
    Join Date
    Aug 2004
    Location
    S.E. Pa
    Posts
    6,135

    Cool overfeeding Quad pellet stoves

    I recently diagnosed this problem with my In-laws Castile insert. Turns out the reset button stuck 'on'. I tapped on it, it popped back out and has been fine since. I've never had to replace a reset button so I assume it was an isolated event. Unfortunately, the way this button is wired in is not conducive to servicing. You cannot simply disconnect it to Ohm it out or jump it out as the case may be.

    I agree w/ JTP on the the CB 1200 having very few problems I've heard of. IT sounds like your firepot gate was not fully closed. It is a fine line btw these gates fitting tight enough so burning pellets don't drop into the ash pan versus fitting loosely for easier operation. The operator needs to ensure the gas is fully closed after each dump.

    Hearthman

  5. #200
    Join Date
    Jan 2009
    Posts
    3

    Hmm

    We cleaned it daily. Vacuumed it out. Made sure the firepot was closed. No clinkers. We just really got a lemon stove. Even the rep from the store said so. He had one other one that they had to send back to the manufacturer. Thanks for your input. I know for a fact the firepot was closed. I vacuum the entire area out and put a tool in the firepot to make sure the holes are open and the firepot is closed. Thanks anyway.

  6. #201
    Join Date
    Jan 2009
    Posts
    3
    I also have a Quadra fire mt vernon stove, actually it is an insert. My house filled with smoke the other night and I noticed the circuit breaker in my house panel had tripped. I pulled apart the stove today and vacuumed out the combustion/convection blowers. I clean the baffles faithfully. Now, I see a red light flashing inside of the control panel of the stove. There are two steady green lights on top then a steady red light below those two and then the flashing light below the steady red light and kind of "inside" the panel. any ideas?

  7. #202
    Join Date
    Jan 2009
    Posts
    3
    Bad control panel. They replaced mine twice. Still had problems. I went through two months of problems with my stove. I followed the book to the letter on maintaining it. It finally had a bad fire in the ashpan. Everything in this stove was replaced and replaced. I got fed up and worried about a house fire. The men at the Fireplace Store came and picked my stove up. They told me that they had just returned another stove exactly like mine due to same problems. They were both lemons and went back to the factory. I replaced mine with the Sante Fe model which I love and having no problems with. Hope you get things figured out. I get real tired of people posting that I wasn't cleaning it enough or properly. I was anal about cleaning and maintain my stove daily.

  8. #203
    Join Date
    May 2005
    Location
    Madison, WI
    Posts
    1,078
    Quote Originally Posted by paulex7920 View Post
    I also have a Quadra fire mt vernon stove, actually it is an insert. My house filled with smoke the other night and I noticed the circuit breaker in my house panel had tripped. I pulled apart the stove today and vacuumed out the combustion/convection blowers. I clean the baffles faithfully. Now, I see a red light flashing inside of the control panel of the stove. There are two steady green lights on top then a steady red light below those two and then the flashing light below the steady red light and kind of "inside" the panel. any ideas?
    It is normal for the control board to flash red on the AE unit. Not sure what would have tripped the breaker? Do you have a lot of other things on the same circuit? Computers? Mini-Fridge? Its possible some other things were drawing a load when the stove went to ignite and combined it was over 15amps tripping the breaker.

  9. #204
    Join Date
    Jan 2009
    Posts
    3
    Just found out that my mt. vernon insert is not an AE model. I bought it new 10/06 and was told yesterday that the latest and greatest were not mfg. until 07. figures, This flashing red light I'm told is the unit calling for heat? Ok, so I cleaned the stove out spotless, and power it back up. wifey see's a flash by the control panel and thenthe breaker trips in my house panel. This is a dedicated breaker B.T.W. Dead short somewhere I'd say in the stove.

  10. #205
    Join Date
    May 2005
    Location
    Madison, WI
    Posts
    1,078
    In a standard mt vernon unit (non-AE) there should not be a flashing red light. There are two red lights on that unit. One would be the call for heat light which I belive is on the back of the stove, the other is a status light inside the control box. I am guessing the flashing is from in the control box and must be an error light, but I am not sure what it means exactly.

    If you turn the stat down so its not calling for heat does it still throw the breaker?

  11. #206
    Join Date
    Jan 2009
    Posts
    3

    Unhappy

    Yes, I disconnected the battery back-up and plugged the unit back in. Once I turned the T-stat back on, the breaker tripped along with a flash at the control panel? enough to scare the bejesus out of the wife. I have a tech from the dealer coming out on Friday armed to the teeth with wiring harness, blowers, etc. etc. Through process of elimination I gather, They will hopefully fix the damn thing. interesting to note is that lately, (since Nov.-Dec.) I noticed the glass seems to get black rather quickly almost daily! Once a month I'm pulling the baffle plate out and vacuuming the whole stove out. Also, weekly I clean out the exhaust pipe which is only 4' long. I pulled the blower housing apart yesterday and inspected that and there was no blockage there as well. Combustion air problem?

    Quote Originally Posted by jtp10181 View Post
    In a standard mt vernon unit (non-AE) there should not be a flashing red light. There are two red lights on that unit. One would be the call for heat light which I belive is on the back of the stove, the other is a status light inside the control box. I am guessing the flashing is from in the control box and must be an error light, but I am not sure what it means exactly.

    If you turn the stat down so its not calling for heat does it still throw the breaker?

  12. #207
    Join Date
    May 2005
    Location
    Madison, WI
    Posts
    1,078
    if you have a battery backup cord you plug into the unit and hook right to a battery you have an AE unit. Would be easier to help if you actually knew what insert you had. If you are just using a power inverter or something (and dont have an AE unit), then the first place I would look for a problem is the ignitor. I'm sure the tech you have coming will check that, so good luck.

  13. #208
    Join Date
    Feb 2009
    Posts
    1

    Mt. Vernon Pellet Stove Nightmare

    The stove has worked well, HOWEVER, I cannot get service. The dealer refers me to one person only who has told me himself that he works half a year and travels the other half. I have been trying to get service now for the other half of a service call that began over a year ago. I have had to work on it myself because I have been stood up over 12 times. I reported this to the Mt. Vernon folks and the lady who took the information would not tell me when someone would contact me or who the regional rep was. She said she did not know the name of the CEO or Director of Marketing. No other store dealer will help me since I did not buy this stove at their store. There is a terrible shortage of people who can work on these here in Georgia. After a 3 week delay, Mr. Vernon apparently contacted this service person directly, he called me, reemed me out for calling the factory and hung up on me. What an experience! In addition, I bought 3 tons of pellets at once because I was told by two dealers that there would only be one load of pellets to Georgia this year. I had problems last year as well. My suggestion is to make sure you can get service and pellets. I am very discouraged and feel between a rock and a hard place. I don't think this guy is emotionally stable, the people who own the store where I bought the stove don't seem to care, and Mt. Vernon will not contact me directly. Suggestions anyone? I have called every dealer listed for 100 miles. Brookskh

    Put your email address in your profile, Thank you.
    Last edited by beenthere; 02-10-2009 at 07:21 AM. Reason: Email address in post

Page 16 of 17 FirstFirst ... 691011121314151617 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event