Page 1 of 6 123456 LastLast
Results 1 to 13 of 77

Hybrid View

  1. #1
    Join Date
    Nov 2012
    Location
    Tahlequah OK
    Posts
    131

    Question oil pressure problem

    I have a 10 ton Copeland discus and a 15 ton copelamatic on a rack system. This is a R22 system. They share a common hot gas line and suction line. The discus maintains a constant oil pressure out put at the pump of 90 pounds. The copelamatic on start up has a oil pressure output of about 85 pounds but it slowly falls and eventually trips my oil pressure control. The discus is a new compressor. The previous discus was doing the same thing. It busted one of the connector rods. The oil pump is new, I have a crank case heater on the comp and there is no foaming in the sight glass. The oil level is 1/2 way up the sight glass. I have installed a new oil separator on the system and it works great. This system is at a Save A Lot store and takes care of medium temp display boxes. It seems like there is an internal oil leak in the compressor causing the oil pressure to fall off. Has anyone encountered this problem before?

  2. #2
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,833
    broken connecting rod!!!!!!!!!!!!1

    sorry!

    but that is most likely your problem!

    frank
    I WILL SELL WORK,GENERATE BUSINESS, GO GET NEW CUSTOMERS!
    YOU SHUT THE HELL UP AND QUIT RUNNING YOUR MOUTH!

  3. #3
    Join Date
    Sep 2007
    Location
    NH
    Posts
    1,217
    Check the pressure difference between crankcase and suction valve... How new is this compressor?

  4. #4
    Join Date
    Nov 2004
    Location
    up in the hizzy
    Posts
    1,440
    I would drain the oil check the screen and the pump, it doesnt take long to do it!

  5. #5
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,833
    and you can reverse rotation too!!!!!!!!


    Quote Originally Posted by valdelocc View Post
    I would drain the oil check the screen and the pump, it doesnt take long to do it!
    I WILL SELL WORK,GENERATE BUSINESS, GO GET NEW CUSTOMERS!
    YOU SHUT THE HELL UP AND QUIT RUNNING YOUR MOUTH!

  6. #6
    Join Date
    Nov 2004
    Location
    up in the hizzy
    Posts
    1,440
    Quote Originally Posted by supertek65 View Post
    and you can reverse rotation too!!!!!!!!
    Thats right, although there maybe gunk floating around.

    whats up with all the chillers avatars? I liked the pink donut better! chillers are the new hvac fashion!I'm a big boy working on big intimidating chillers blah blah blah if I ever get an avatar it would be a window shaker

  7. #7
    Join Date
    Nov 2006
    Location
    Southeastern Pa
    Posts
    19,564
    Frank, that reminds me.

    I have to buy a bench grinder!!!!!!!
    [Avatar photo from a Florida training accident. Everyone walked away.]
    2 Tim 3:16-17

    RSES CMS, HVAC Electrical Specialist

    AOP Forum Rules:







  8. #8
    Join Date
    Jul 2009
    Location
    In a mechanical room....
    Posts
    1,888
    LOL
    “It takes courage to grow up and turn out to be who you really are.”

    - E.E. Cummings

  9. #9
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,950
    Quote Originally Posted by welling service View Post
    I have a 10 ton Copeland discus and a 15 ton copelamatic on a rack system. This is a R22 system. They share a common hot gas line and suction line. The discus maintains a constant oil pressure out put at the pump of 90 pounds. The copelamatic on start up has a oil pressure output of about 85 pounds but it slowly falls and eventually trips my oil pressure control. The discus is a new compressor. The previous discus was doing the same thing. It busted one of the connector rods. The oil pump is new, I have a crank case heater on the comp and there is no foaming in the sight glass. The oil level is 1/2 way up the sight glass. I have installed a new oil separator on the system and it works great. This system is at a Save A Lot store and takes care of medium temp display boxes. It seems like there is an internal oil leak in the compressor causing the oil pressure to fall off. Has anyone encountered this problem before?
    Couple things.

    #1. Telling us output pressure is, largely, meaningless. You need to properly measure NET oil pressure, or pump outlet pressure minus crankcase pressure. With a Copeland, that should be 50#.

    #2. This 'Copelametic' compressor... Well, a 15HP Copelametic doesn't tell me a whole lot. How about model numbers?


    While you're there getting the above information, do me a favor, IF the "copelametic" compressor is a 4D model (one with two heads) pump it down and pull the oil screen.

    I would think that, with a broken rod, you'd have a lot of noise and vibration which you haven't described.

  10. #10
    Join Date
    Nov 2012
    Location
    Tahlequah OK
    Posts
    131
    I know how to check net positive oil pressure. The pump out put pressure is the one that falls. The suction remains constant. Read the post a little closer. I said that the discus has been replaced because it was the one with the busted rod. I have pulled the oil screen and it is clean and I have changed the oil also. It is a 4D model with two heads.
    Quote Originally Posted by jpsmith1cm View Post
    Couple things.

    #1. Telling us output pressure is, largely, meaningless. You need to properly measure NET oil pressure, or pump outlet pressure minus crankcase pressure. With a Copeland, that should be 50#.

    #2. This 'Copelametic' compressor... Well, a 15HP Copelametic doesn't tell me a whole lot. How about model numbers?


    While you're there getting the above information, do me a favor, IF the "copelametic" compressor is a 4D model (one with two heads) pump it down and pull the oil screen.

    I would think that, with a broken rod, you'd have a lot of noise and vibration which you haven't described.

  11. #11
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,950
    Quote Originally Posted by welling service View Post
    I know how to check net positive oil pressure. The pump out put pressure is the one that falls. The suction remains constant. Read the post a little closer. I said that the discus has been replaced because it was the one with the busted rod. I have pulled the oil screen and it is clean and I have changed the oil also. It is a 4D model with two heads.
    You'll forgive, then, my assumption that you don't know how to measure it because you didn't post it.

    As I said, output pressure of the pump is largely meaningless in this scenario.


    How fast does the pump pressure drop off?

  12. #12
    Join Date
    Nov 2012
    Location
    Tahlequah OK
    Posts
    131
    It starts up at about 85PSI and then drops to around 50 PSI. My CC pressure is about 25 PSI. I never see much variation in the suction pressure. It will run like this for various times and sooner or later trips on low oil pressure. It has run for two weeks one time before tripping. I have not had my gauges on it when it trips so I don't know if the pump output is going down or the CC pressure is coming up. I have done a piston blow by test and found no problem. The comp. pumps down just fine and holds. I thought maybe the OPC was bad so I installed a new one with the same results. The oil pump is newly installed because at first I thought the pump was worn and not maintaining pressure. I have never run up on this problem before and I don't mind saying I AM STUMPED!!

  13. #13
    Join Date
    Nov 2004
    Location
    up in the hizzy
    Posts
    1,440
    Quote Originally Posted by welling service View Post
    It starts up at about 85PSI and then drops to around 50 PSI. My CC pressure is about 25 PSI. I never see much variation in the suction pressure. It will run like this for various times and sooner or later trips on low oil pressure. It has run for two weeks one time before tripping. I have not had my gauges on it when it trips so I don't know if the pump output is going down or the CC pressure is coming up. I have done a piston blow by test and found no problem. The comp. pumps down just fine and holds. I thought maybe the OPC was bad so I installed a new one with the same results. The oil pump is newly installed because at first I thought the pump was worn and not maintaining pressure. I have never run up on this problem before and I don't mind saying I AM STUMPED!!
    it may not even be an oil related issue, maybe the compressor is tripping on overload, have you thought about that?

Page 1 of 6 123456 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event