Results 1 to 4 of 4

Threaded View

  1. #1

    Trane XV80 Destroying Multiple Igniters

    Greetings - I am very grateful to locate your forum Purchased my Trane XV80 in 10/2003 & system has performed quite well - until last winter. Long story short, zero heat/cold winter day - called contractor - diagnosed hot surface igniter - quoted $., had presence of mind to research part via internet ($) & source compatible part for WR 768A-15 through local supplier the next day. 1st (compatible-cobbled-together) igniter failed within 2 weeks, given a direct replacement & this got me through last winter. I ordered two spares (WR 768A-15) from Pex two weeks ago, which was a good thing because the igniter failed again yesterday. Replaced with igniter from Pex, (this is taking me about 5 minutes now) & bam, the world is good again & my significant other returns to the usual complaints of everything I am not doing particularly well with - BESIDES THE IGNITER...

    Can someone PLEASE help me understand the next step(s) for troubleshooting what may be causing these igniters to fail?

    Thank you for your time and consideration.
    Last edited by Chris_Worthington; 11-11-2012 at 01:21 PM. Reason: Pricing Removed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event