Results 1 to 5 of 5
  1. #1

    15kw heat kit is only heating 1 coil

    This is a brand new heat kit HKR-15C and goodman air handler MBR1200AA. I do not have a heat pump or A/C. After installation, everything came on, except on the heat strip only 1 coil is heating. Had an electrician test every wire and he said everything is getting power appropriately. Is it just a faulty heat strip or or is something hooked up wrong? The installation instructions were followed exactly.

  2. #2
    Join Date
    Jun 2001
    Location
    Moore, Oklahoma, United States
    Posts
    4,505
    Could be either. Normally something is hooked up wrong.

  3. #3
    Join Date
    Jun 2009
    Location
    NYC
    Posts
    463
    HVAC guys know allot more about these stuff than electricians.

  4. #4
    Join Date
    Dec 2002
    Location
    SouthEast NC ICW & Piedmont Foothills
    Posts
    7,635
    you need to call whomever installed it and have them figure it out, if you installed it yourself; now it's time to pony up the money to get it installed correctly and operational.
    It`s better to be silent and thought the fool; than speak and remove all doubt.

  5. #5
    Join Date
    Dec 2005
    Location
    Cincinnati, Oh
    Posts
    5,317
    Call out a professional.

    Extremely easy fix, for someone familure with goodman (or any for that matter) equitment.
    "Better tell the sandman to stay away, because we're gonna be workin on this one all night."

    "Dude, you need more than 2 wires to a condenser to run a 2 stage heatpump."

    "Just get it done son."

    Dad adjusted

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event