Results 1 to 3 of 3

Hybrid View

  1. #1
    Join Date
    Jun 2008
    Location
    Baltimore, MD
    Posts
    17
    Post Likes

    Appion TEZ 8 pump and oil.

    Went to use mine for the 3rd/4th time today after changing the oil and had issues pumping past 2000 microns. Switched to a 6CFM pump and had no issues.

    Now that I'm thinking about it I didn't use Appion oil but standard vacuum pump oil that I use in every other pump. Anyone do this with negative effects? At time I was thinking it wouldn't make a difference but now I'm regretting my choice.



    Any other feedback on this pump?

  2. #2
    Join Date
    May 2011
    Location
    Oklahoma
    Posts
    373
    Post Likes
    I think people have used non-appion oil before with good success. Did you change anything when you swapped pumps at all?

  3. #3
    Join Date
    Jun 2008
    Location
    Baltimore, MD
    Posts
    17
    Post Likes
    Thread Starter
    Nothing at all. Noticed it was taking an unusual amount of time for the system to pull down so I valved off the system and tried to pull only the gauges and micron gauge down. Would not pull under 700-800 microns. Switched pump and that one pulled the gauges down to 200 ish, full system to 400 in about 10min or so.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.