I am working on a site with 3 NAE's. There is no ADX or ADS. The NAE's and SCT Tool are at Version 2.2

One of the NAE's need to be replaced. I can get a NAE, but this one is the latest version (I believe 5.2)

Do I need to downgrade the new NAE to Version 2.2..and is this even possible ???
Or can the NAE 5.2 coexist with the other NAE's at version 2.2 and can it be downloaded with SCT 2.2 ??