Results 1 to 3 of 3
  1. #1

    Goodman Furnace not turning on

    Hello,

    I have Goodman GMPN060-3 Rev B furnace (LP) that does not turn on. Prior to this problem, it would turn on and run for a few seconds and then shut off. The igniter was replaced last winter and someone recommended to clean the flame sensor.

    While trying to remove the connector from the flame sensor plug (stuck on there pretty well), the metal rod separated from the insulation (spins freely inside the insulation) so I ordered a new one. While waiting for the new flame sensor to arrive, I cut the power to the furnace via circuit breaker.

    After installing the new sensor, I set the thermostat to 85 and now the furnace will not kick on. The igniter doesn't fire up and I don't hear the familiar clicking from the furnace. When I switched the fan from "Auto" to "On", the fan does come on. Also, the diagnostic LED is a solid red so no blinking.

    Any help would be greatly appreciated.

  2. #2
    Join Date
    Dec 2011
    Location
    San Antonio, TX
    Posts
    381
    Not a DIY forum. The only help we can offer is to call a service company.

  3. #3
    Join Date
    Dec 2008
    Location
    Buffalo NY
    Posts
    3,078
    Sounds like you may have blown the board. Call out a tech.


    Sent from my iPad using Tapatalk HD
    Join http://scopeny.org/ Shooter’s Committee on Political Education

    The world is full of sheep,try not to join the flock.

    Support the Skilled Trades, Don't DIY

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event