Results 1 to 8 of 8
  1. #1
    Join Date
    Aug 2005
    Location
    iowa
    Posts
    1,649

    bacharach tech 60

    Hey guys my bacharach tech 60 combustion analyzer just started reacting very slow. I've used it several times in the last month and just yeaterday it started doing this. Even after it acted slow, it later acted normal again. Now today its slow again.

    Is my pump failing? I hear it running and it never changes tone or anything like that. Any ideas?
    Thanks in advance

    Jeep

  2. #2
    Join Date
    Feb 2012
    Location
    MOUNT BETHEL, PA
    Posts
    14
    It may be neeeding a calibration? when was the last one? Does the O2 read normal?

  3. #3
    Join Date
    Aug 2005
    Location
    iowa
    Posts
    1,649
    I ended up just sending it in... we will see what they say

  4. #4
    Join Date
    Feb 2010
    Location
    In a boiler room
    Posts
    7,142
    Do you have a Dwyer 460 draft gauge? It should peg the ball to the top if you connect it to your meter. Maybe the pump is getting weak.

  5. #5
    Join Date
    Aug 2005
    Location
    iowa
    Posts
    1,649
    Ugh. I'm insulted!!!... of coarse I have a dwyer 460.....now that you say it I also remember that it would peg the ball.... oh well I sent it in... hopefully I will remember next time... as. Always thanks for the help chuck!

  6. #6
    Join Date
    Dec 2004
    Location
    Metro Atlanta, GA
    Posts
    214
    have you heard what the problem is? My pump has stopped working. Also, the display is wonky. It's about 4 years old and has not been abused. I saw where they will fix it on their website for around $400. Not sure it is worth it. I am wodering what the cost was for you.

  7. #7
    Join Date
    Nov 2004
    Location
    up in the hizzy
    Posts
    1,386
    Quote Originally Posted by jcbecker View Post
    have you heard what the problem is? My pump has stopped working. Also, the display is wonky. It's about 4 years old and has not been abused. I saw where they will fix it on their website for around $400. Not sure it is worth it. I am wodering what the cost was for you.
    Save your money and buy a Testo. Bacharach are overpriced junk, I used them for years and they keep getting worst and worst.

  8. #8
    Join Date
    Aug 2005
    Location
    iowa
    Posts
    1,649
    Quote Originally Posted by jcbecker View Post
    have you heard what the problem is? My pump has stopped working. Also, the display is wonky. It's about 4 years old and has not been abused. I saw where they will fix it on their website for around $400. Not sure it is worth it. I am wodering what the cost was for you.
    not yet. its only been gone a couple weeks. also the boss sent it to the supply house and let them send it to bacharach. so im sure it will take longer to get my overpriced piece of junk fixed.... i will post the problem once i find out.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event