Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2008
    Location
    LEHIGH VALLEY, PA
    Posts
    165

    viking ice machine vuim150ss

    looks like it might be a badged whirlpool , has a low voltage cutter grid , Switch on and absolutely nothing happens , power to machine and the on switch is on and checked , no lights or beeps, there are 2 thermistors evap and bin, evap reads 2.6 ohm and the bin reads .05 ohm . as they where at the same temp i would have expected a similar reading . question is would a faulty bin stat shut down every thing [ as i suspect ] and does may one know what type of probes they use .

  2. #2
    Join Date
    Mar 2007
    Location
    Toronto
    Posts
    259
    It's a whirlpool, same as KitchenAid or others. Scotsman tech support should have the ohm readings. Just say it's a Scotsman and they will help.
    1-800-Scotsman

  3. #3
    Join Date
    Oct 2009
    Location
    Raleigh, NC
    Posts
    802
    Those readings should be at least in the thousands of ohms. The 2.6 is probably 2,600 and you didn't notice the "K"on your meter screen"? The .05 is definitely wrong. I'm pretty sure the machine will start with a bad evap thermistor but maybe not with a bad bin thermistor. Try switching them temporarily and see what happens.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event