Results 1 to 5 of 5
  1. #1
    Join Date
    Oct 2007
    Location
    Huntsville, AL
    Posts
    399

    bacnet device id.

    I am trying to set up a jace with dual rs-485 cards, the first floor is on one and the second on the other. My problem is when I discover my units on the second floor they go in to fault because of duplicate device id's , if I change the id it will not communicate with the device. Id there a way to change the device id? These are distech vvt controllers.


    Im like a mushroom, they keep me in the dark and feed me crap.

  2. #2
    Join Date
    Dec 2004
    Location
    San Francisco Bay Area
    Posts
    474
    Does the device manager show you a "Device ID..." button? Either that, or is there a right-click action that allows you to change the device ID? (Much of my device address changing happens in WEBS with Honeywell Spyders, so I can't remember what functionality is present in a Vykon BACnet environment).
    If the Distech controllers behave anything like a network of Spyders, you will need to change the device IDs one-at-a-time, starting with the controller with the highest MAC ID seen on the network...sounds strange, I know, but trust me, it's the only way to straighten out duplicate device ID's if you've got a whole network of controllers connected to your JACE.

  3. #3
    Join Date
    Jul 2008
    Posts
    1,460
    Quote Originally Posted by CountryBumpkin View Post
    I am trying to set up a jace with dual rs-485 cards, the first floor is on one and the second on the other. My problem is when I discover my units on the second floor they go in to fault because of duplicate device id's , if I change the id it will not communicate with the device. Id there a way to change the device id? These are distech vvt controllers.
    You got the 2 different comm ports as 2 different bacnet networks (different Network Numbers) yeah?

    The comm ports each have a MSTP (MAC) address (typically 0 but you may have changed it) ... what ever it is must be clashing with another in the field.
    (ah...the joys of Bacnet!)

    ...are you sure it is duplicate IDs ... we have had problems with MSTP and the wrong cable, noise, terminations, differences in earth potential between floors(!!!) ...though mostly just duplicate Mac addressing

    how do you KNOW it isnt wiring???...i mean a duplicate address should be easy to find just cut the bus into segments, one half lives and the other half dies etc etc

    ...got more than one Jace...like an MSTP/ETH router...theres another MAC address that could be clashing

    Like Davem says ... probably have to go through each field device on at a time and make sure you know what its MAC is ... I advise a table relating MAC, DevID, and physical location.
    This is one place where the KMC auto Addressing really rocks.
    Each device comes already with a unique(-ish) DevID ... assign a controller as the 'Anchor" and it starts handing out MAC addresses to everybody on the bus...(very LON-like )

    I personally think it is utterly absurd to be expected to mac address controllers before field installation ... the exception is unless the MAC is set by DIP sw.
    Last edited by MatrixTransform; 09-25-2012 at 04:42 PM. Reason: whimsy
    1 + 1 = 3 ( *** for very large values of 1)

    ...everybody wants a box of chocolates and long stemmed rose

  4. #4
    Join Date
    Oct 2007
    Location
    Huntsville, AL
    Posts
    399
    I know for a fact that it is not wiring because I can delete the device that has the same device id and it will start communicating. I was able to fix the problem by changing the device id like davem suggested but my problem is now it will not let me change all my devices, it is giving me an error saying it can not find the existing device id! Ugh....

  5. #5
    Join Date
    Dec 2004
    Location
    San Francisco Bay Area
    Posts
    474
    It may be a little late for this, but sometimes you actually have to refresh the page you're on (the BACnet Device Manager) - I've seen where manual changes to addressing in the database (MAC or device ID) aren't reflected in the table until you refresh the page...then changing the device ID will work better.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event