Results 1 to 7 of 7
  1. #1

    ICE-O-MATIC STARVING EVAPORATOR

    I have a ICE-O-MATIC under counter model ICEU220 this thing has had 3 technicians parts changing on it. The problem is that the evaporator forms ice on the bottom and little to no ice on top. the copper line running into the evap is frozen but the copper line coming out aint freezing. i was concerned about the charge so i recoverd the refrig and weighed in the correct amount. and i still only freezes the bottom of the evap. and its not pulling the suction down to cut in the low pressure control to start the freeze timer. so it dont go into harvest. I checked the water purge valve and its not leaking. I checked the hot gas valve their is a big temp difference. but the the copper line going out of the HGV doesent freeze about a inch and a half . Im thinking a bad txv. but im not sure if the HGV is not closing all the way? Is their a good test to check the HGV or txv?

  2. #2
    Join Date
    Dec 2004
    Location
    WI
    Posts
    312
    HGV is easy to test. If discharge line is red hot and inlet of hgv is red hot too its leaking. dont do temp diff across valve as it will lie to you. If discharge line of comp is red hot and INLET side of HGV is not after 5 mins then its not leaking.
    TXV - Call Ice o matic tech support. Or get their tech handbook.
    The postings on this site are my own and don't necessarily represent The Manitowoc Company's positions, strategies, or opinions.

  3. #3
    Join Date
    Oct 2011
    Location
    Chicagoland Area
    Posts
    4,754
    Before you condemn the valve, check the serpentine?
    Officially, Down for the count

    YOU HAVE TO GET OFF YOUR ASS TO GET ON YOUR FEET

    I know enough to know, I don't know enough
    Liberalism-Ideas so good they mandate them

  4. #4

    RE: ICE-O-MATIC STARVING EVAPORATOR

    Quote Originally Posted by darrin0819 View Post
    I have a ICE-O-MATIC under counter model ICEU220 this thing has had 3 technicians parts changing on it. The problem is that the evaporator forms ice on the bottom and little to no ice on top. the copper line running into the evap is frozen but the copper line coming out aint freezing. i was concerned about the charge so i recoverd the refrig and weighed in the correct amount. and i still only freezes the bottom of the evap. and its not pulling the suction down to cut in the low pressure control to start the freeze timer. so it dont go into harvest. I checked the water purge valve and its not leaking. I checked the hot gas valve their is a big temp difference. but the the copper line going out of the HGV doesent freeze about a inch and a half . Im thinking a bad txv. but im not sure if the HGV is not closing all the way? Is their a good test to check the HGV or txv?
    I am a Field Service Manager with IOM. From your description, you are having feed problems with your Expansion Valve. If the HGV was not closing, your pressure would be higher, not lower. Serpentine Separation, as mentioned by another subscriber, on these units are really no longer an issue.

  5. #5
    thanks for the reply.. My customer has already had a few guys changing out parts on this ice machine. IT supposedly had a new low pressure control installed, a new timer, new relay, new water pump. last thing i want is to be wrong.. I know the HGV works I made it go into harvest it does open and close. i just didnt know if the coil was getting weak not allowing the valve to close completly?The evap is not seperated from the refrigerant lines. Bad txv is my thinking. whats serpentine seperation mean?

  6. #6
    Join Date
    Oct 2011
    Location
    Chicagoland Area
    Posts
    4,754
    Quote Originally Posted by darrin0819 View Post
    thanks for the reply.. My customer has already had a few guys changing out parts on this ice machine. IT supposedly had a new low pressure control installed, a new timer, new relay, new water pump. last thing i want is to be wrong.. I know the HGV works I made it go into harvest it does open and close. i just didnt know if the coil was getting weak not allowing the valve to close completly?The evap is not seperated from the refrigerant lines. Bad txv is my thinking. whats serpentine seperation mean?
    This
    Officially, Down for the count

    YOU HAVE TO GET OFF YOUR ASS TO GET ON YOUR FEET

    I know enough to know, I don't know enough
    Liberalism-Ideas so good they mandate them

  7. #7
    Join Date
    Jun 2004
    Posts
    896
    Why so many tech working on it?
    Why are we changing so many parts?

    You said hgv is ok and you feel the txv is bad cause it not feeding
    Then why can't you get the suction pressure down?
    Bad txv will cause short cycle cause it will close cut in pressure
    Right away.

    When you weigh in the charge
    Did you check your pressures as the machine starts
    What were they?

    Turn off water pump and check to see if pressures will drop
    Check if suction line start to freeze
    You might have a weak compressor.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event