Results 1 to 3 of 3
  1. #1

    Magic-Pac AC/Gas Furnace Not Working after Powerwashing Outside?

    I had a Magic-Pac AC/Gas Furnace 24,000 BTU with a 410-A system installed in a condo that I own in November 2009. I currently have tenants at the property. They said that the air conditioning was working fine two days ago but that after a power washing company came to power-wash the exterior of the condo buildings yesterday, that it stopped working. They also reported seeing some white smoke in the living room of the condo.

    My property management company dispatched an electrician to the property regarding the "white smoke" issue to make sure that there wasn't an electrical problem. They also asked the electrician to take a quick look at the HVAC system. He looked at the HVAC and said that it was fried and something about all of the freon being gone and that the freon may have caused the white smoke?

    I am hoping to have the contractor that installed the HVAC go look at this issue but since it's a holiday weekend, I wanted to see if I could get any ideas from this board.

    One thing to note is that the water valve that the power washers may have used is on the other side of the wall from where my HVAC is stored. Also, the interior shut-off for the exterior water valve is right next to the HVAC. So one of my question is, is an HVAC hooked up to a water supply? If so, would it be possible that if the power washers used the water for a few hours that it would've deprived my HVAC of water and caused it to shut down? Note that there was no actual water in the unit so I don't think there was any leak.

    I hope I explained everything correctly. I would appreciate any thoughts you may have until I can get the contractor to take a look at it after the Labor Day Weekend.

  2. #2
    Join Date
    Oct 2010
    Location
    Anderson, South Carolina, United States
    Posts
    6,747
    No that unit does not use water, it is air cooled. Could just be a coincidence. Sounds like the compressor went poof

  3. #3
    Quote Originally Posted by jtrammel View Post
    No that unit does not use water, it is air cooled. Could just be a coincidence. Sounds like the compressor went poof
    Thanks for your reply. If that's the case, I'm hoping that the 5 year warranty on parts will kick in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event