Results 1 to 10 of 10
  1. #1
    Join Date
    Aug 2012
    Posts
    2
    Post Likes

    Post NOT SO COOLING COOLER

    Have a r12walkin cooler that started with a condensing fan replacement and a liquid line leak.
    Converted to r414b (r12 drop-in) but would not cool below 50'F. Replaced txv with no luck.
    Suction pressure running at 52 psi and sh at 10'F. Head pressure running at 150 psi which seems low.
    would you think that maybe the compressor is leaking ( valve) and needs to be replaced?

    rob

  2. #2
    Join Date
    Aug 2006
    Location
    Florida (some where) way-south
    Posts
    230
    Post Likes
    Dude
    I never have use 414- I use 409 for a replacement.
    doing one call at a time.


  3. #3
    Join Date
    Feb 2006
    Location
    USA
    Posts
    4,381
    Post Likes
    409 is expensive as hell these days. To many other choices that will save the end user $ while not effecting your profit.

    Sent from my SCH-I800 using Tapatalk 2

  4. #4
    Join Date
    Sep 2010
    Location
    Western, MO
    Posts
    874
    Post Likes
    Why is your suction 52 PSI? This is what you need to find out. I can't believe it is getting below 60.

    jim
    Common sense isn't very common anymore.

  5. #5
    Join Date
    May 2000
    Location
    Indianapolis, IN, USA
    Posts
    35,956
    Post Likes
    Isn't that Hot Shot? If so, you can call ICOR's tech support. 866-433-TECH. Only used it once replacing 134 in a cooler. Isn't 50 a bit high on the low side? Seems to me that's a very warm coil if I recall right.

  6. #6
    Join Date
    Jul 2012
    Location
    Western KY
    Posts
    1,221
    Post Likes
    Valve comp out on suction side and see if it pumps down into vaccume. If it does not pitch or replace valve plate.

  7. #7
    Join Date
    Jan 2010
    Posts
    3
    Post Likes

    dirty condenser?

    just throwing this out there , try blowing out the condenser.
    I know your SH should be higher if condenser was dirty but still worth a try.
    It reminds me of a WI cooler i had that wouldn't pull temp after a compressor change, and TXV replacement. Blew out the condenser and pressures stabilized and it ran normal.

    Also a condenser fan replacement could be from a dirty condenser.

  8. #8
    Join Date
    Dec 2005
    Posts
    1,957
    Post Likes
    Quote Originally Posted by Conaire View Post
    Have a r12walkin cooler that started with a condensing fan replacement and a liquid line leak.
    Converted to r414b (r12 drop-in) but would not cool below 50'F. Replaced txv with no luck.
    Suction pressure running at 52 psi and sh at 10'F. Head pressure running at 150 psi which seems low.
    would you think that maybe the compressor is leaking ( valve) and needs to be replaced?

    rob
    52 PSIG = 46 degrees saturated temp ---- that is not good sign for medium temp ---- one of the pistons is not pumping

  9. #9
    Join Date
    Jun 2010
    Location
    Miami
    Posts
    271
    Post Likes
    Don't guess. Get the performance chart and see if the compressor is operating correctly. Not enough info is given to say for sure.

  10. #10
    Join Date
    Aug 2012
    Posts
    2
    Post Likes
    Going to replace compressor as it will not pump down. Thanks Guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Quality Home Comfort Awards