Results 1 to 3 of 3

Hybrid View

  1. #1

    Need Assistance with a Taylor 754 water cooled

    Hello everyone, I am new to the forum but have stopped in several times the last year reading some responses when I had equipment issues.

    I have a Taylor 754 water cooled ice cream machine. It was recently purchased in May and I was informed it was completely refurbished. However, when it came off the truck, we quickly found out it was not. We were delayed in getting open, so we installed the machine and the guy promised he would bring us the proper machine the following week. Needless to say, he still has not done this and it is a constant battle with getting him to answer calls.

    We are having an ongoing problem with the right side that houses the chocolate 10% soft serve mix flaking up. I clean my machine every other day and put new blades on every month. The guy that sold me the machine sent a repair guy out and he first off started to blame it on lack of water pressure. That didn't work. Then he said I don't clean the machine enough. I fought back with my cleaning schedule, then it was my blades were old, but I just put new ones on, and showed him my old ones and he agreed they still had a good bit of life on it. Then he blammed it on not priming the machine properly. All this is hogwash IMO, as this is my 14th year in business and I never had the problems I am having now.

    After going back and forth, he removed (the dryer?) he said it probably got some air in it and that caused the problem. He took readings and was on his way. About 20 mins after he left, the machine started to make a high pitched noise and shut off right away. He came back and said it was the water pressure again, yet there is no problems on the vanilla side and we have great pressure here. Then he said it probably got a calcium build up in the line. He flushed lines, did some adjustments, hit some freon in the machine and it worked. Came in the next morning and it did the exact same thing. I called for over a week with no answer from him. I called our local Taylor rep in Maryland and they said it would be a week or so before they can get someone out. So for a week, I went without the chocolate side and then finally the guy that sold me the machine sent a repairman out. He showed up and right away replaced the water value and the machine started to work. He said he knew when he left the last time it was bad, but didn't have one on the truck and didn't have time. ERGH

    Within 2 days of him fixing this, I started to have the same issues again of the chocolate side being too soft and then flaking up. Even if we do no adjustments. Now I have another problem. I got a call from my shop and they told me the machine is completely froze up in the hoppers. I told them to turn the machine off and shut down and put a sign on the window and I was on my way. I got there and the hoppers had to be scooped out, that is how thick it froze up. We weren't busy yesterday due to weather, so they were not putting mix in as often as usual to notice. I got everything cleaned up, drained the machine and clean and started over and adjusted the hopper temp. Within 30 mins, it was all freezing up again. I then adjusted again and the exact same thing. I called the repairman but he says to keep adjusting. I have it adjusted as far back as it can go and the machine is still freezing up. Right now I am having to turn off the machine between each use and then turning back on to avoid the ice build up. The guy I bought the machine from said he is not sure what is happening and can't come for a week. Call Taylor and they said it will be 4 - 5 days before they can send someone out.

    I do have a friend that offered to help out if I can get a gist for what is going on. I opened up the side panel and the line from the small compressor to the hopper seems to be frozen solid with frost. Does anyone have any suggestions? I do have an attorney working on getting me what I paid for on the machine end, but in the meantime, I need to try to get this machine going.

    Thanks for any assistance you can give.

  2. #2
    Join Date
    Mar 2001
    Posts
    81
    Quote Originally Posted by scoopgirl View Post
    Hello everyone, I am new to the forum but have stopped in several times the last year reading some responses when I had equipment issues.

    I have a Taylor 754 water cooled ice cream machine. It was recently purchased in May and I was informed it was completely refurbished. However, when it came off the truck, we quickly found out it was not. We were delayed in getting open, so we installed the machine and the guy promised he would bring us the proper machine the following week. Needless to say, he still has not done this and it is a constant battle with getting him to answer calls.

    We are having an ongoing problem with the right side that houses the chocolate 10% soft serve mix flaking up. I clean my machine every other day and put new blades on every month. The guy that sold me the machine sent a repair guy out and he first off started to blame it on lack of water pressure. That didn't work. Then he said I don't clean the machine enough. I fought back with my cleaning schedule, then it was my blades were old, but I just put new ones on, and showed him my old ones and he agreed they still had a good bit of life on it. Then he blammed it on not priming the machine properly. All this is hogwash IMO, as this is my 14th year in business and I never had the problems I am having now.

    After going back and forth, he removed (the dryer?) he said it probably got some air in it and that caused the problem. He took readings and was on his way. About 20 mins after he left, the machine started to make a high pitched noise and shut off right away. He came back and said it was the water pressure again, yet there is no problems on the vanilla side and we have great pressure here. Then he said it probably got a calcium build up in the line. He flushed lines, did some adjustments, hit some freon in the machine and it worked. Came in the next morning and it did the exact same thing. I called for over a week with no answer from him. I called our local Taylor rep in Maryland and they said it would be a week or so before they can get someone out. So for a week, I went without the chocolate side and then finally the guy that sold me the machine sent a repairman out. He showed up and right away replaced the water value and the machine started to work. He said he knew when he left the last time it was bad, but didn't have one on the truck and didn't have time. ERGH

    Within 2 days of him fixing this, I started to have the same issues again of the chocolate side being too soft and then flaking up. Even if we do no adjustments. Now I have another problem. I got a call from my shop and they told me the machine is completely froze up in the hoppers. I told them to turn the machine off and shut down and put a sign on the window and I was on my way. I got there and the hoppers had to be scooped out, that is how thick it froze up. We weren't busy yesterday due to weather, so they were not putting mix in as often as usual to notice. I got everything cleaned up, drained the machine and clean and started over and adjusted the hopper temp. Within 30 mins, it was all freezing up again. I then adjusted again and the exact same thing. I called the repairman but he says to keep adjusting. I have it adjusted as far back as it can go and the machine is still freezing up. Right now I am having to turn off the machine between each use and then turning back on to avoid the ice build up. The guy I bought the machine from said he is not sure what is happening and can't come for a week. Call Taylor and they said it will be 4 - 5 days before they can send someone out.

    I do have a friend that offered to help out if I can get a gist for what is going on. I opened up the side panel and the line from the small compressor to the hopper seems to be frozen solid with frost. Does anyone have any suggestions? I do have an attorney working on getting me what I paid for on the machine end, but in the meantime, I need to try to get this machine going.

    Thanks for any assistance you can give.
    Flaking is caused by product being overbeaten and breaking down. Could be caused by several things. Same goes for hoppers freezing. Taylors are specialized equipment, not everybody can work on them. Best bet is to wait for Taylor.

    Good Luck

  3. #3
    Join Date
    Nov 2008
    Posts
    1,673
    I think almost anyone would say that the present method that the tech is using is not working.

    For power line problems the Power Companies have recording voltmeters that babysit the power line (but they will only hook it up if you specifically ask for it).

    For car problems that only show up occasionally the dealers have data recorders triggered by the fault or the driver, that then dump data from several different test points in the vehicle wiring (but they will only hook it up if you specifically ask for it and sometimes they will deny even having such a device).

    Does anyone make a data logging machine that monitors several points in an HVAC system so that when the tech gets there, he knows exactly what all was happening before the machine failed?
    I can imagine this rented chart recorder would be monitoring and recording voltages, currents, pressures and temperatures, sampling these test points at probably once per minute.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event