Results 1 to 5 of 5
  1. #1
    Join Date
    Aug 2012
    Location
    El Tigre Venezuela
    Posts
    4

    Confused CHILLER CARRIER 30GTN040 PROBLEM

    Good morning friends of the forum.
    I have a problem with a Carrier chiller ComfortLink 30GTN040 208v/3ph/60Hz FREON 22. Displays the alarm code A207 (Cooler Freeze Protection). Probable cause: Faulty thermistor T1 (Leaving fluid temperature) or T2 (Entering fluid temperature).
    I replace with new T1/T2 thermistors thermistors but continued failure and code A207 is displayed again. Thus the EWT value displayed on the screen is -24 degrees F. I take reading in the MBB and the voltage drop between pins is 1.68vdc which corresponds to 71 degrees F according to the table in the equipment manual.
    Why does the displayed value does not match at all with the readings taken with the voltmeter vdc?.
    It may be that there is a problem in software or hardware or there will be some programmable parameter or option to be changed?
    This cooler conditions the emergency unit of a hospital.
    Please I need urgent help.
    Thanks for your help

    Sorry for my English.
    I translating by Google Traslator.
    from Venezuela

  2. #2
    Join Date
    Mar 2011
    Location
    North Carolina Piedmont Area
    Posts
    449
    I will look this up for you tomorrow, But could it be that you put in a wrong thermistor 3k ohm versus 10K or vise versa, a quick way of checking is to remove the thermistor cable/plug from the board and use a decade box such as a IEC Resistance Decade Box, RS-200 and wire with an extra plug and input the corresponding ohms value for 77 degrees. This should display a correct temperature readout on your display/readout.

  3. #3
    Join Date
    Mar 2011
    Location
    North Carolina Piedmont Area
    Posts
    449
    VOLTAGE DROP A FOR THERMISTORS T1, T2 are 5k ohm and should be 1.538 VDC @ 77 degrees F , or 4,976 ohms.
    or 1.538 VDC @25 degrees Celsius or 5,000 ohms.
    verify that you have not installed a 10k sensor.

    Hope this helps

    Trouble shooting is not part of the repair..........understand the symptoms and you will find a solution.

  4. #4
    Join Date
    Feb 2008
    Location
    Dubai
    Posts
    94
    Dear did you check any loos connection or cable cut,becouse we had faced same issues,
    Quote Originally Posted by aagosti2 View Post
    Good morning friends of the forum.
    I have a problem with a Carrier chiller ComfortLink 30GTN040 208v/3ph/60Hz FREON 22. Displays the alarm code A207 (Cooler Freeze Protection). Probable cause: Faulty thermistor T1 (Leaving fluid temperature) or T2 (Entering fluid temperature).
    I replace with new T1/T2 thermistors thermistors but continued failure and code A207 is displayed again. Thus the EWT value displayed on the screen is -24 degrees F. I take reading in the MBB and the voltage drop between pins is 1.68vdc which corresponds to 71 degrees F according to the table in the equipment manual.
    Why does the displayed value does not match at all with the readings taken with the voltmeter vdc?.
    It may be that there is a problem in software or hardware or there will be some programmable parameter or option to be changed?
    This cooler conditions the emergency unit of a hospital.
    Please I need urgent help.
    Thanks for your help

    Sorry for my English.
    I translating by Google Traslator.
    from Venezuela

  5. #5
    Join Date
    Jan 2008
    Location
    Dallas ,Texas
    Posts
    3,702
    First question are you reading the machines in Celsius or Fahrenheit?

    Are you getting a 5VDC power on the prongs with the thermistors off?

    Are the other sensor inputs on the MBB reading correctly?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event