Page 3 of 3 FirstFirst 123
Results 27 to 30 of 30

Thread: YORK YK CHILLER

  1. #27
    Join Date
    Jan 2011
    Posts
    1,173
    Quote Originally Posted by Goldfang View Post
    Hi all I have just found out that the chiller was caused due to insufficient refrigeration .
    If you mean refrigerant, I find that curious. If the pictures you sent were taken when the machine was at 88% FLA, it seems unusual to me that the evaporator small difference was 1.2*F. Usually the small difference temperature would be much greater in a low refrigerant charge situation.

    Glad you solved your problem.

  2. #28
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,833
    LMAO!!!!!!


    Quote Originally Posted by york56 View Post
    Pretty pictures nice sounds dosen't help much I guess we will be asking Siri whats wrong with my Chiller next !

  3. #29
    Join Date
    Sep 2004
    Location
    Kansas City, Kansas, United States
    Posts
    13,833
    Approach of 1 att 90 percent fla?

    No way it was low on REFRIGERATION!!!





    Quote Originally Posted by KnewYork View Post
    If you mean refrigerant, I find that curious. If the pictures you sent were taken when the machine was at 88% FLA, it seems unusual to me that the evaporator small difference was 1.2*F. Usually the small difference temperature would be much greater in a low refrigerant charge situation.

    Glad you solved your problem.

  4. #30
    Join Date
    Apr 2012
    Location
    Louisiana
    Posts
    674
    Quote Originally Posted by Goldfang View Post
    Dear knewyork we just take over this building chiller services contract , a few month ago this building started on a energy saving project on the hvac system but they have a very bad urgument with the previous service contractor. When we took over this servicing site we then notice that something wrong with chillers it can't unload like as before! ( noticed by owner )! And I'm not very familiar with this York yk chiller that why I'm here in this forum.
    Argument was most likey about energy management taking over control of pumps, causing the problems you are seeing now.

    Or maybe I've been tainted by past experience with ems.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event