Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2012
    Posts
    1

    Scotsman Ice machine.

    I'm normally do HVAC and a customer of mine has asked me to look at his ice machine. I have worked on a few in the past but this is not on "like to do" list.Its a Scotsman Prodigy Ice Machine. The freeze cycle is long and ice is forming on the lower end of the grid only. The ice is very thick and when it goes into harvest it comes out in one block.Can you give a suggestion on what I should check.

  2. #2
    Join Date
    Jun 2012
    Posts
    116
    if its only making ice on the bottom, its going to be most likely either an undercharge or TXV problem. You will want it to harvest all of the cubes at once with a 1/8" bridge connecting them. Can you give a model number/serial number, and operating pressures?

  3. #3
    Join Date
    Jul 2011
    Posts
    10
    Are both lines in and out of evap plate frosting up? sounds like a charge issue or potential metering device.

  4. #4
    Join Date
    Mar 2007
    Location
    Toronto
    Posts
    259
    You want to make sure the water valve is not leaking thru. You can pull the hose off after fill or check the sump full light on the board.
    If the sump full light is always on you either have a dirty probe or a water valve leaking thru. If the sump empty light goes on you likely have
    a leaking dump valve which if large could produce the thin ice symptoms.

  5. #5
    Join Date
    Jul 2012
    Location
    Western KY
    Posts
    1,221
    Charge or TXV most likely.

  6. #6
    Join Date
    Dec 2011
    Location
    Michigan
    Posts
    119
    Me too

    With large emphasis on the low charge. Check the quick connects for leaks.

    Sent from my amazing 4G device

  7. #7
    Join Date
    Oct 2004
    Location
    Rochester, NY
    Posts
    149
    Go to http://www.scotsman-ice.com/?xhtml=x...downloads.html and choose your model number to download the service guide.

  8. #8
    Join Date
    Sep 2011
    Location
    Fayetteville, NC
    Posts
    130
    ditto on the quick connects if its a remote. Oil is a the dead giveaway for any IM that has a history.

    Verify the pressures and charge if needed or you can pull the charge and weigh it in. I like the weighing in part on remotes.

    But the block ice points to an undercharge and/or txv issue.

  9. #9
    Join Date
    Aug 2012
    Location
    Georgia
    Posts
    27
    Does this unit have a hot gas bypass valve? If so check to see if it is leaking through while in a freeze cycle. You can feel the front and back side of the valve to check the temp. Hot on back cool on front. It does sound like a low charge as others have previously said, but I have had to replace a few of these valves myself.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event