Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2012
    Posts
    1
    Post Likes

    Hmm Mold showing up at a few registers after blowing in insulation

    I live in florida and 4 months ago had fiberglass insulation added in my attic over the 20yo stuff that was not sufficent. We added enough to bring it up to R45 which covered existing HVAC ductwork. Just recently some mold began appearing at a couple of the registers. I am sure the ducts we covered. Could this insulation covering the duct work be causing this mold to apprear? Thanks in advance for your thoughts.

  2. #2
    Join Date
    Jan 2004
    Location
    PA
    Posts
    70,003
    Post Likes
    Yes, specially if he registers and register boxes/boots aren't sealed to the ceiling/attic side.
    Contractor locator map

    How-to-apply-for-Professional

    How many times must one fix something before it is fixed?

  3. #3
    Join Date
    Aug 2010
    Location
    West Monroe, LA
    Posts
    1,583
    Post Likes
    I agree with beenthere. I would pull down all the registers in the home and look for gaps that would be letting non condition air meet condition air. If this is the case get a few tubes of caulk/silicone and seal the gaps. Replace the registers that are discolored. Also might want to replace them all so they will look the same.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Quality Home Comfort Awards