Results 1 to 3 of 3

Thread: Freezing Over

  1. #1

    Freezing Over

    8 year old Lennox Elite series 3 Ton system. Florida
    System has worked flawless for 8 years, and recently began freezing over on occasion.
    I called a local contractor who came out, he checked my Freon level and said it was spot on. He checked my coil and said it was clean. He checked the amperage pull of blower in my air handler and it was correct and seems to be blowing fine.
    The drain was very plugged, but that is now fixed, and a duct was loose from a cold air vent, and that is fixed.
    Still freezing over.
    I set it on 72 last night, and it worked fine all night. I got up at 7 this morning and it was 72 in the house. I work from home and I just noticed it was 75 in the house. I turned the compressor off and I am currently only running the fan, ice cold water is draining from my drain.

    Ideas?

  2. #2
    Join Date
    Aug 2003
    Location
    Fort Worth, TX
    Posts
    11,346
    Have you recently changed what type of filter you use in this system, given that for eight years prior you did not have this problem? If you have gone to a higher MERV filter, this may be the culprit.

    Come to think of it, have you changed the filter recently?

    Has anything in the house been placed in front of any of the air returns?

    If you have an airflow issue causing the system to ice up, that should have been something the tech would spot if he ran superheat and subcooling checks on the system while it was running. If all he did was check gauge pressure and nothing else, he may have missed a clue that could lead him to the problem.
    • Electricity makes refrigeration happen.
    • Refrigeration makes the HVAC psychrometric process happen.
    • HVAC pyschrometrics is what makes indoor human comfort happen...IF the ducts AND the building envelope cooperate.


    A building is NOT beautiful unless it is also comfortable.

  3. #3
    Filter is a bit of an odd size. So I stock up on em when I find em. But I changed it when the problem started, and the tech changed it again when he was here, both with the same kind. He looked at it and said it was fine.
    I just started the system back up, as the water stopped draining from the pipe. I went around with a sheet of notebook paper and put in on all the returns, they are all sucking pretty good.
    One bedroom, which is a storage room, I had the register closed, because we didn't want to cool this room, there is a return in this room though.
    I just opened that register back up, so all the registers in the house are now open.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event