Results 1 to 7 of 7
  1. #1
    Join Date
    Jul 2012
    Location
    Richland, WA
    Posts
    248

    Frymaster Hi Temp Failure

    My work is going to send me to the next Frymaster training class that is closest to the Northwest and so I'm having to do most of my learning on Frymaster hands on right now.

    I was working on an electric Frymaster fryer that after they drained the oil and put new oil in, it started going to Hi Temp Failure within a few minutes of turning the computer on.

    So I started by unplugging the cable from the board inside that connects to the computer, then reconnecting it, but it still went to Hi Temp Failure with a few minutes after turning the computer on.

    So I went out to the van to get a different cable to see if it was the problem but I didn't have another computer with the same style connector so I just tried a newer computer and it never went to Hi Temp failure at all.

    What would have been the fastest way to get to the diagnosis.

  2. #2
    Join Date
    Oct 2008
    Location
    mid-Tennessee
    Posts
    695
    Quote Originally Posted by caheiman30 View Post
    What would have been the fastest way to get to the diagnosis.
    Appears to me you did good. A few things to remember about Frymaster controls:

    1. As on ANY fryer, there's a seperate hi limit thermostat. However, on Frymasters, it simply disables the heat circuit. The only reflection it will have on the controller would be indication for HELP or IGNITION FAILURE - depending on which controller you have.

    2. If the controller says HI (or a variation thereof), that's always going to be due to what the computer is reading from the temperature probe circuit. One of two things has happened: either the oil temp IS well in excess of setpoint (I don't remember exactly how much over) - OR - there's a faulty connection (high resistance or an open ) somewhere in the probe circuit.


    FYI: On older Frymaster electrics (back in the '90s, I think), the temp probe was mounted to the element, with it and a KX style high limit subject to much abuse there. Frymaster then switched to the temp and hi limit probes they already employed on their gas fryers. This change greatly improved their fryer's reliability.

    Fast forward to the past few years to newer problems. For connections to the controller, Frymaster stopped using that large, white Molex connector to the computer and went to the flatter, black SMT (surface-mount technology) connector. I've seen MANY problems arise from this "less than secure" type of connection, including the one you described. Thankfully, Frymaster didn't double up on that trouble with the connection to the interface board. The Molex connector is still used there. In my opinion, the SMT connectors need to be redesigned right back out of their fryers.

  3. #3
    Join Date
    Jul 2012
    Location
    Richland, WA
    Posts
    248
    It was a computer with a white Molex connector on both sides that was in there and I replaced it with one that had the SMT connector on the computer.

    There is a gas fryer that is one of the split vats doing the same thing at another store, I'm going to be asking the boss if I can try changing the computer there also to see if it solves the problem there. The split vat works one day all day no problems, and after they shut it off and drain the oil and filter it back in when they turn it back on it goes into Hi Temp Failure and sometimes probe failure.

    Quote Originally Posted by ECtofix View Post
    Appears to me you did good. A few things to remember about Frymaster controls:

    1. As on ANY fryer, there's a seperate hi limit thermostat. However, on Frymasters, it simply disables the heat circuit. The only reflection it will have on the controller would be indication for HELP or IGNITION FAILURE - depending on which controller you have.

    2. If the controller says HI (or a variation thereof), that's always going to be due to what the computer is reading from the temperature probe circuit. One of two things has happened: either the oil temp IS well in excess of setpoint (I don't remember exactly how much over) - OR - there's a faulty connection (high resistance or an open ) somewhere in the probe circuit.


    FYI: On older Frymaster electrics (back in the '90s, I think), the temp probe was mounted to the element, with it and a KX style high limit subject to much abuse there. Frymaster then switched to the temp and hi limit probes they already employed on their gas fryers. This change greatly improved their fryer's reliability.

    Fast forward to the past few years to newer problems. For connections to the controller, Frymaster stopped using that large, white Molex connector to the computer and went to the flatter, black SMT (surface-mount technology) connector. I've seen MANY problems arise from this "less than secure" type of connection, including the one you described. Thankfully, Frymaster didn't double up on that trouble with the connection to the interface board. The Molex connector is still used there. In my opinion, the SMT connectors need to be redesigned right back out of their fryers.

  4. #4
    Join Date
    Oct 2008
    Location
    mid-Tennessee
    Posts
    695
    Quote Originally Posted by caheiman30 View Post
    There is a gas fryer that is one of the split vats doing the same thing at another store, I'm going to be asking the boss if I can try changing the computer there also to see if it solves the problem there. The split vat works one day all day no problems, and after they shut it off and drain the oil and filter it back in when they turn it back on it goes into Hi Temp Failure and sometimes probe failure.
    At a McDonald's I take it, since few others use split vats.

    With such an intermittent problem that's nearly impossible it pinpoint, I would at least attempt a new temp probe FIRST since it's the far cheaper alternative to resolving their issue. Otherwise, if you slap in a expensive computer and the problem reoccurs, they're paying for it even if it wasn't the problem.

    If you DO decide to replace the computer, I'd suggest you replace that temp probe along with it.

  5. #5
    Join Date
    Nov 2003
    Location
    Wisconsin
    Posts
    458
    I haven't been around for awhile so this is late. Quick way to check for computer problem, which this error can be is to switch the puter with the one nex t door to it.
    In my many years I have come to a conclusion that one useless man is a shame, two is a law firm, and three or more is a congress. John Adams

    The whole aim of practical politics is to keep the populace alarmed (and hence clamorous to be led to safety) by menacing it with an endless series of hobgoblins, all of them imaginary. H. L. Mencken

    "Life's tough......It's even tougher if you're stupid."
    -John Wayne

  6. #6
    Join Date
    Dec 2012
    Location
    Illinois
    Posts
    289
    If all your stores use Frymaster fryers, something to think about would be the Frymaster computer test box. It's a tool they sell to aid in troubleshooting computers. I think it will work for the M2000 but not the M3000 so if you have any LOV fryers it may not help you. As someone else posted, usually you can prove a bad computer by swapping computers with the adjacent fryer. As also mentioned, the "hi" error means that the computer thinks that the probe is telling it that the oil is more than like 15-20 degrees above set point. If you can recreate the scenario to make it say "hi" then them the oil real quick and see what the computer is saying for temp. If its off by more than 5 degrees then you either have a bad probe, bad connection on the probe circuit somewhere, or the probe could have too much carbon build up causing it to hold temp and skew the reading. The last one is a problem that will cause the temp t be off far enough to cost you points on your FOR/SOR.

    GOOD LUCK

  7. #7
    Join Date
    Dec 2012
    Location
    Columbus OH
    Posts
    32
    Sounds like you did the right thing..Great job

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event