Results 1 to 13 of 13
  1. #1
    Join Date
    Jan 2007
    Location
    Illinois
    Posts
    114

    Commercial unit kicking out on Low Pressure!!

    10 ton commercial package unit that is kicking out on low pressure, instantly hitting 0 Psig when compressor kicks in. Obvious restriction and unit has metrering device built into manifold on evap coil. Tried to back flush but no luck!! Has anyone experienced this issue before and if so what was the outcome?????

  2. #2
    Join Date
    Mar 2011
    Location
    North Carolina Piedmont Area
    Posts
    448
    What is the Brand and model of the unit?

  3. #3
    Join Date
    Mar 2011
    Location
    North Carolina Piedmont Area
    Posts
    448
    Where is the head pressure at. It is not very likely that it pulls down so quick even with a plugged orifice or TXV it would normally take as long as 20 to 30 seconds to pull down if say ambient temperature/pressure.

    What type of metering device do you have. What is the LRA and RLA when it runs? Is it a scroll or recip?

  4. #4
    Join Date
    May 2002
    Location
    evansville indiana
    Posts
    943
    had a carrier puron unit doing this to me last week ,,, I was thinking oh great a clogged header ,, I was relived when I noticed the sweat on the line leaving the drier and it was cold , relpaced it and all was good... ... you did check the drier ?
    mikeacman

  5. #5
    Join Date
    Mar 2011
    Location
    North Carolina Piedmont Area
    Posts
    448
    Quote Originally Posted by mikeacman View Post
    had a carrier puron unit doing this to me last week ,,, I was thinking oh great a clogged header ,, I was relived when I noticed the sweat on the line leaving the drier and it was cold , relpaced it and all was good... ... you did check the drier ?
    That is very true, those blue oval units have had many problems with those new coils. have had many coils and liquid dryers replaced. I have seen factory installed dryers which are undersized. This is standard OEM.

  6. #6
    Join Date
    Apr 2012
    Location
    Paper Street Soap Company
    Posts
    2,304
    Quote Originally Posted by jvpettis View Post
    10 ton commercial package unit that is kicking out on low pressure, instantly hitting 0 Psig when compressor kicks in. Obvious restriction and unit has metrering device built into manifold on evap coil. Tried to back flush but no luck!! Has anyone experienced this issue before and if so what was the outcome?????
    Don't assume metering device. It takes it a bit to pump down on metering restriction and then all of them would have to be restricted completely.

    I would be looking at the liquid drier real close.

  7. #7
    Join Date
    Jan 2007
    Location
    Illinois
    Posts
    114
    Quote Originally Posted by Six View Post
    Don't assume metering device. It takes it a bit to pump down on metering restriction and then all of them would have to be restricted completely.

    I would be looking at the liquid drier real close.
    I agree so I completely removed drier after haveing free flow through it but same issue.

  8. #8
    Join Date
    Jan 2010
    Posts
    6,056
    Is there one or two refrigeration circuits in that unit ?

  9. #9
    Join Date
    Apr 2012
    Location
    Paper Street Soap Company
    Posts
    2,304
    Quote Originally Posted by jvpettis View Post
    I agree so I completely removed drier after haveing free flow through it but same issue.
    Hmmmmm....Well time to get the tubing cutters out and a bottle of nitro and a nozzle and isolate the restriction. ( find it )

    Actually I would just unsweat the manufacturers connections. Easy enough.

    If it IS the header go to wall of fame section.

    I posted a pic by pic informative "how to" on those Carrier headers. They're actually not a big deal.

  10. #10
    Join Date
    Jan 2007
    Location
    Illinois
    Posts
    114
    Quote Originally Posted by VTP99 View Post
    Is there one or two refrigeration circuits in that unit ?
    There are two refrigeration circuits in this unit. First stage was running but on hot hot days it starts to kick out on high pressure? and I am pretty sure that both stages are not piped together.

  11. #11
    Join Date
    Jan 2010
    Posts
    6,056
    What you describe I usually see happen on a bad TXV. Will pump right down and the head will start to rise than stop.
    Is it a Carrier ?

  12. #12
    Join Date
    Jan 2007
    Location
    Illinois
    Posts
    114
    Quote Originally Posted by Six View Post
    Hmmmmm....Well time to get the tubing cutters out and a bottle of nitro and a nozzle and isolate the restriction. ( find it )

    Actually I would just unsweat the manufacturers connections. Easy enough.

    If it IS the header go to wall of fame section.

    I posted a pic by pic informative "how to" on those Carrier headers. They're actually not a big deal.
    Looked at pics, Nice work and exactly what i'm dealing with. But I have to ask what was causing your restriction????

  13. #13
    Join Date
    Jan 2007
    Location
    Illinois
    Posts
    114
    Quote Originally Posted by VTP99 View Post
    What you describe I usually see happen on a bad TXV. Will pump right down and the head will start to rise than stop.
    Is it a Carrier ?
    Not a Carrier, Its a ICPCommercial Gas pack

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event