Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2012
    Location
    Los Angeles, CA
    Posts
    10

    Taylor Soft Serve Model 754 issues - need help!!

    ...i have a Taylor 754 in my shop that has been working fine for the last year ... about three weeks ago ... one of the employees calls me and says when she tried to put one side of the machine on auto in the morning all she heard was a beep but didn't feel the machine actually click and start working like the other side did... so i went to check and found out that the overload had tripped so i pushed the reset on that side and machine worked fine... that lasted for about 2 weeks... then same scenario happened again...so i did the same thing... this past week it happened about 5 times... so i thought initially maybe the problem was the viscosity was set too high and product might be freezing harder causing the motor to draw too much amperage and tripping the over load... after i reset it i brought viscosity setting all the way down until the machine cut out on its own and was able to cycle in and out a few cycles while i was there with no tripping... but yesterday i get another call and guess what.... the same problem!!! ... so i went and checked the machine and figured maybe the reset button OL is defective so i bypassed it... and machine worked fine for a couple of hours while i was there... on my way home empyee called me and said machine is making a squealing loud noise and SMOKING from the back so i asked the employee to shut it off and was able to put on wash cycle later on and empty product... so my guess is that squealing was due to the belts slipping on pulleys and maybe product was too stiff for beater to turn??? smoking is from belts rubbing??? i am not sure what is going on....can the control board be intermittent and work fine some times and crap out and freeze product rock solid at other times... i am sure the squealing and smoking would not have happened had i not bypass the OL trip switch cuz the OL switch would have cut the machine out before any squealing and smoking can occur...but i am not sure what is the root cause for OL tripping to beging with at this point...when i turned the viscosity down the machine was cycling fine for the few cycles as I was monitoring!... can the gear box be intermittent and jam up and seize at times...although I did not hear any odd noises of damaged bearing or anything like that... i need your experience with this... and i appreciate your time... sorry for the long winded explanation... but i tried to describe everything in detail to get the best advice...

  2. #2
    Sorry to hear you are having such a hard time with your machine. I have a taylor 754 as well that I am having a hard time figuring out how to adjust the viscosity on and was hoping you could tell me how to do so.

  3. #3
    Join Date
    Sep 2003
    Location
    North-Central Ohio
    Posts
    22
    Quote Originally Posted by Ash- View Post
    ...i have a Taylor 754 in my shop that has been working fine for the last year ... about three weeks ago ... one of the employees calls me and says when she tried to put one side of the machine on auto in the morning all she heard was a beep but didn't feel the machine actually click and start working like the other side did... so i went to check and found out that the overload had tripped so i pushed the reset on that side and machine worked fine... that lasted for about 2 weeks... then same scenario happened again...so i did the same thing... this past week it happened about 5 times... so i thought initially maybe the problem was the viscosity was set too high and product might be freezing harder causing the motor to draw too much amperage and tripping the over load... after i reset it i brought viscosity setting all the way down until the machine cut out on its own and was able to cycle in and out a few cycles while i was there with no tripping... but yesterday i get another call and guess what.... the same problem!!! ... so i went and checked the machine and figured maybe the reset button OL is defective so i bypassed it... and machine worked fine for a couple of hours while i was there... on my way home empyee called me and said machine is making a squealing loud noise and SMOKING from the back so i asked the employee to shut it off and was able to put on wash cycle later on and empty product... so my guess is that squealing was due to the belts slipping on pulleys and maybe product was too stiff for beater to turn??? smoking is from belts rubbing??? i am not sure what is going on....can the control board be intermittent and work fine some times and crap out and freeze product rock solid at other times... i am sure the squealing and smoking would not have happened had i not bypass the OL trip switch cuz the OL switch would have cut the machine out before any squealing and smoking can occur...but i am not sure what is the root cause for OL tripping to beging with at this point...when i turned the viscosity down the machine was cycling fine for the few cycles as I was monitoring!... can the gear box be intermittent and jam up and seize at times...although I did not hear any odd noises of damaged bearing or anything like that... i need your experience with this... and i appreciate your time... sorry for the long winded explanation... but i tried to describe everything in detail to get the best advice...

    Hello
    754's are gravity fed and if the barrel (cylinder) is starved for product the air/product ratio goes up and can cause a freeze-up condition that will increase the beater load(amps).
    Here is what I would check starting from the simplest to the more complicated:

    Are they outdrawing the machine (pulling more product than it can freeze) which usually happens during warm weather when they have high demand?

    Are the mix feed tube and air orifice correct and not plugged?

    Are they letting the mix level drop below the mix feed tube inlet hole?

    All of the above is relative to the critical "mix to air" ratio which should be roughly
    1/3 air to 2/3 product.

    If all of the above is correct, then I would check the gearbox, logic board, power board, and compressor contactor(for sticking contacts).

    What you have described breaks down into three possible causes. Either the refrigeration system is running too long per cycle(with the beater not turning), a mechanical issue in the gearbox/ drive shaft/beater assy. or the barrel is being starved of product.

    Hope this helps!
    Scott
    Last edited by cool_tech_llc; 08-07-2012 at 11:32 PM. Reason: mistake

  4. #4
    Join Date
    Jul 2012
    Location
    Los Angeles, CA
    Posts
    10
    thank you so much for your valuable breakdown of the possible causes of failure!! after long troubleshooting I found out that it was the power board, for whatever reason it was intermittent, at random occasionss it will prolong the freezing cylce to the point where the product would get to hard for the beater to turn it! does the power board drive the big compressor three phase contactor? it seems so...

    i have another question now, in regards to the settings on the logic board, let me explain it this way, in my store when we close out for the day we place all machines on standbuy and go to the hoppers and flip the air valves (i am not sure why i was told to flip the air valves???can explain that one??) anyway, the next morning when we open up all the machines would have the product in liquid form but very cold, i would say the temp of product is in the range of 38-40 except for one machine where the product stays frozen (watery but frozen) on one side? which setting is correct? and how do i achieve the optimum setting?

    that same machine from time to time seems to stop cooling the mix in the hopper both hoppers not just the side that stays frozen after standby, what we found was if we tunred machine off and let it set fora couple of hours the hoppers start to cool again? i am thinking both issues might be related and maybe something is freezing up the lines of the hopper cooling system? but how do i adjust it not sure!!!!

  5. #5
    Join Date
    Jul 2012
    Location
    Los Angeles, CA
    Posts
    10
    Quote Originally Posted by yummee807 View Post
    Sorry to hear you are having such a hard time with your machine. I have a taylor 754 as well that I am having a hard time figuring out how to adjust the viscosity on and was hoping you could tell me how to do so.
    Ok this is what i found out that worked for me, adjust the viscocity all the way up and start the machine with fresh liquid yogurt, start testing product temperature until it reaches any where between 16 - 18, at that point turn the viscosity down (CCW) until compressor stops, this should maintain FroYo temperature in that range! maybe there is a better way for doing it, if you come across a better way please do share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event