Results 1 to 4 of 4
  1. #1
    Join Date
    Feb 2012
    Location
    Kansas
    Posts
    9

    york Yk Optiview blank screen

    Having issues with 2 yk optiview chillers that have a blank screen intermittently. The first chiller will randomly have a blank screen if you shut off the main disconnect at the vfd. If I unplug J1 power supply to the board the screen will the go through its tests and boot up. My vdc power supply is within range, also note this is the 1730 and not the 2430 board also. the other chiller is a 2430 board and it shut down the other day in run mode. troubleshot the two fuses on the board and the connector @J1 screen came back up and have not had the problem since thinkin about installing new fuses on board i could see how the pegs on those could wear a little and have connection issues. I have also seen on here that there is a mention of and updated power cable avaialble for the chillers did not know if anyone has that info. handy. any help is appreciated.

  2. #2
    Join Date
    Jan 2011
    Posts
    1,180
    There was a problem with the harnesses on some early Optiview panels. Other boards had a problem where they would go into a reboot and never come out of it. If it were me, I would order a new harness for the power supply to the microboard. There are two P/Ns. The 8" is 571-02264-272 and the 12" is 571-03774-272.

  3. #3
    Join Date
    May 2012
    Location
    California
    Posts
    242
    We recently had the same problem it is a YK with newer microboard we replaced power supply and it went away. We had to pull the J1 connector also. Power supply checked out ok but it was dropping out when we were'nt there.

  4. #4
    Join Date
    Aug 2006
    Location
    Mixing oil and fire with a big spoon.
    Posts
    4,396
    Quote Originally Posted by JEF1980 View Post
    We recently had the same problem it is a YK with newer microboard we replaced power supply and it went away. We had to pull the J1 connector also. Power supply checked out ok but it was dropping out when we were'nt there.
    we have been finding a lot of those J1 connector harnesses failing...make sure you always order the longer one...makes my wife happy too!
    When the rich wage war, it's the poor who die - Linken Park

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event