Page 2 of 2 FirstFirst 12
Results 14 to 17 of 17
  1. #14
    Join Date
    Jun 2006
    Location
    Richmond, VA
    Posts
    2,990
    Quote Originally Posted by joemach View Post
    I work for a Carrier dealer and would not want to stock or install the thermostats they sell.

    I like Honeywell better.
    I actually carry honeywells too

    But do like the edge and infinity controller.......but I am not going to carry those high dollar stats.......

  2. #15
    Join Date
    Sep 2007
    Location
    State College, PA
    Posts
    1,170
    Quote Originally Posted by beshvac View Post
    I actually carry honeywells too

    But do like the edge and infinity controller.......but I am not going to carry those high dollar stats.......
    I agree!
    Can someone please explain to me -
    Why is there never enough time to do it right the first time, but plenty of time to do it twice?


    Please view site rules: http://hvac-talk.com/vbb/showthread.php?t=1241

    Apply for Pro Membership: http://hvac-talk.com/vbb/showthread.php?t=116113

    Find your local HVAC-Talk Contractor: http://icemeister.net/aop_map.html

  3. #16
    Join Date
    Apr 2009
    Location
    MA
    Posts
    24
    Quote Originally Posted by second opinion View Post
    They would be wrong. The 800 is one of the simplest T stats to set up.

    What is the problem with yours? When did you have the system installed and what was the equipment?
    Half of the screen became unresponsive. It's 3 years old.

  4. #17
    Join Date
    Apr 2009
    Location
    MA
    Posts
    24
    Quote Originally Posted by motoguy128 View Post
    I beleive they use pin bases on those thermostats, so there may not be any wiring involved, but you will need ot program it.

    Whether or not you can find a installation guide and follow how ot access the system configuration setting depends on how skilled you are with electronics. However, if you set it up incorrectly, it could damage yoru equipment.
    Do you mean program the calendar, schedules, etc. or is there more to it? I was inside the configuration settings recently trying to figure out if anything could be responsible for the screen problem I described above. It seemed pretty straight-forward.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event