TRANE Chiller - RTHD SOLID STATE STARTER
Results 1 to 1 of 1
  1. #1
    Join Date
    Jun 2011
    Location
    Jammu
    Posts
    12

    TRANE Chiller - RTHD SOLID STATE STARTER

    I need your technical suggestions to rectify the below problem, I would like to brief here shortly.
    When we commissioned the RTHD chiller with solid state starter ( Chaina make) chiller it was running in good condition almost 18 hours after that it is started tripping in momentary power loss.
    We have disabled the MPL then it is started tripping in power loss after 10-12 minutes of running.
    Checked all the external controls, Para meter settings of dyna view & SSS & cabling of the chiller related all power loss problems.
    Changed CT, PT, starter module, Power module, dyna view, put the loop for HP cutout, by passed disconnect switch, replaced SS Starter, incoming power analysis, connected separate cable from adjacent chiller, voltage sensing option disabled, checked water flow, bypassed the flow switch & disabled all the power related settings even though same problem (tripping after 10 -15 minutes)

    After these exercise we have opened the compressor checked slide valve movement found to be okay, currently our team is checking the terminal status
    If you have any more technical suggestion pls. advice.
    Last edited by HINDUSTANI; 07-20-2012 at 06:59 PM. Reason: spelling error

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event