Results 1 to 3 of 3

Thread: McQuay rps 105

  1. #1
    Join Date
    Apr 2007
    Location
    Upstate NY
    Posts
    101

    McQuay rps 105

    I have 4 of these units that all seem to post random "pump down alarms" from time to time. I have tested all the obvious and nothing is leaking by. I'm suspecting something electronic but I haven't been able to narrow it down yet. Also, can anyone think of a condition of operation that would flood the coil with refrigerant and not allow it to pump down within the time allowed (120 seconds I think). I don't see flooding or low superheat during normal operation. It seems to be just a nuisance alarm but it disables half the machine, along with those condenser fans, and overloads the other circuit, sometimes causeing high pressure trips, other times causing it to just loose the load and generate a comfort complaint. Any ideas would be appreciated. Thanks.

  2. #2
    Join Date
    Apr 2012
    Location
    So. Fl.
    Posts
    57
    What a out the dehumidifying mode,are your points set too close. Is the unit going into dehumidification and overloading the circuit. May have the circuit setter onthe high side leaking by,which wouldn't show up as a cooling issue.

  3. #3
    Join Date
    Apr 2007
    Location
    Upstate NY
    Posts
    101
    No dehum on these units.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event