Results 1 to 5 of 5
  1. #1
    I have a YORK heatpump airconditioner unit that is about 13 yrs old, lately we have been hitting over 100 degrees,and the unit is working hard. I have had it recharged and all that is well, but after a while the EM light on the thermostat starts blinking. If i shut the unit off for about 15 seconds, the light stops blinking, but after a while it will start up. When I look at the compressor, the fan is not spinning.

  2. #2
    Join Date
    Jun 2003
    Location
    Florida
    Posts
    9,548
    Might want to consider a service call before it becomes an expensive one.....if that fan isn't running it can fry the compressor eventually,not to mention elevating your electric bill.
    If everything was always done "by the book"....the book would never change.

  3. #3
    Join Date
    Sep 2002
    Location
    South Dakota
    Posts
    6,579


    On York units the EM light at the thermostat blinks whenever you have a fault of any kind. You have to dig into the cause of the problem and solve it to get the EM light to quit.

    You need to determine why the fan is not operating. Could be the motor or motor capacitor or perhaps no circuit to the fan for some reason.


  4. #4
    Join Date
    Sep 2002
    Location
    South Dakota
    Posts
    6,579


    If you are not a technician you need to call one.

  5. #5
    Join Date
    Apr 2005
    Location
    NE PA
    Posts
    698
    If you count the blinks, you are most likely seeing 2 flashes, then a pause. This indicates excessively high discharge pressure, due to the non operating fan. As stated, get a service tech to fix the fan before you trash the compressor.

    paul

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event