Results 1 to 10 of 10
  1. #1

    19xr Low Oil Temp

    got a Carrier 19xr that wont start up due to low oil temp. What energizes the oil heater contacts? The oil temp is 80 deg, the microprocessor should be calling for the oil heater. Any thoughts? (got the machine running by unplugging all plugs on the module and screen and plugging them back in.) Dont want that to be the solution, in case the problem occurs again.

  2. #2
    Join Date
    Jun 2012
    Location
    so cal
    Posts
    22
    sounds like a loose connection or even broken one. ohm out your wires with the power off

  3. #3
    i had 15 volts on each side of the contactor coil, seems like something is backfeeding. seems like all the connections were tight. dont know why resetting display would make a difference but it worked

  4. #4
    Join Date
    Oct 2011
    Location
    La.
    Posts
    284
    pic 1 or 2. does it have a 6 pack relay?

  5. #5
    sorry, not sure if 1 or 2. where is six pack relay located? not really a water cooled guru, more of an air cooled guy. whats the diff between 1 and 2?

  6. #6
    Join Date
    Jun 2012
    Location
    so cal
    Posts
    22
    if i remember correctly the pic 1 has smaller characters. the configuration of the display is different. the pic 2 has larger characters. there are other differnces as well, i am not sure if the xr had a pic 1 control? i do know it has a pic 2 control for sure. has anyone seen the pic 3 control?

  7. #7
    Join Date
    Oct 2011
    Location
    La.
    Posts
    284
    the first xr's had pic 1. If you do not know the difference then maybe we should reevaluate you working on this chiller. This is alot of money you are dealing with here. If you try and force the chiller to run with cold oil, you will damage the running gear of the compressor.

  8. #8
    Don't know a lot about Carriers. Tranes are more my speed. Don't think any evaluation is needed. Not forcing machine to run with cold oil anyway. I didn't start it til temp was up to 120. I'm not some light bulb changer who shouldn't be allowed to even look at these machines. Guess I'm just not the chiller god you are^ Just throwing it out there to get some feedback

  9. #9
    It says PIC III on the board

  10. #10
    Join Date
    Aug 2003
    Location
    Fort Worth, TX
    Posts
    11,376
    19XR won't start unless oil temp is above minimum anyhow.

    Could have had dirty connections on your oil sump temperature probe; unplugging and plugging it back in may have cleaned it enough to start working again. Could also be the sensor starting to go bad. If the latter, my condolences. I don't think that sensor sits in a well, which would require the chiller charge to be recovered or moved to one of the barrels in order to change the sensor, but I could be mistaken.
    • Electricity makes refrigeration happen.
    • Refrigeration makes the HVAC psychrometric process happen.
    • HVAC pyschrometrics is what makes indoor human comfort happen...IF the ducts AND the building envelope cooperate.


    A building is NOT beautiful unless it is also comfortable.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event