Page 1 of 2 12 LastLast
Results 1 to 13 of 16
  1. #1
    Join Date
    Jun 2010
    Location
    West Palm Beach
    Posts
    10

    Questionable Compressor?

    I checked a refrigerator compressor which according to the customer had been diagnosed as bad compressor and I found the following readings:
    Run to Start: 2.2 ohm
    Run to Common: .4 ohm
    Start to Common: 2.1 ohm
    I notice that 2.2 and 2.1 are very close could this be an indicative of a bad compressor? How could you diagnose this compressor based upon these readings?
    Thank you

  2. #2
    Join Date
    Jul 2002
    Location
    SE Texas
    Posts
    442
    Start to run readings are very close to the sums of run to common and start to common, so I would not condemn the compressor based on those readings alone.
    With your chrome heart shining in the sun, long may you run.

  3. #3
    Join Date
    Oct 2011
    Location
    Chicagoland Area
    Posts
    4,622
    Did you check anything else?
    Officially, Down for the count

    YOU HAVE TO GET OFF YOUR ASS TO GET ON YOUR FEET

    I know enough to know, I don't know enough
    Liberalism-Ideas so good they mandate them

  4. #4
    Join Date
    Jun 2010
    Location
    West Palm Beach
    Posts
    10
    I did not condemn the compressor either not only for the same reason sandshark mentioned, but primarily because the compressor was not receiving any voltage at all I even left the volt-meter connected to the two power lines on the back of the refrigerator while the owner was turning the timer clockwise with the screwdriver on the bottom front of the refrigerator because I was thinking that the refrigerator was probably on the defrost cycle and we heard the "click" sound several times, but the meter always read zero. It does not have any thermistors (temperature sensors) or mother board that could prevent voltage from reaching the compressor. Maybe it's the timer or the temperature control the problem What do you guys think?

  5. #5
    You did not mention the make / model of this refrigerator which would help in the diagnostics. It appears that you have a defective electical component that is preventing the compressor to start. First I would jump out the temp control followed by checking for voltage at the defrost timer, which by the way is not always present on refrigerators, then ohm out the relay.

  6. #6
    Join Date
    May 2012
    Location
    Winnipeg, MB
    Posts
    9
    I would start by finding where you have voltage and tracing what is keeping it from the compressor. IE, make sure there is voltage entering the Unit then check the first control or switch it goes to, if that component is operating properly move to the next till you find the defective control. I would also jump the defective control out to ensure the compressor is not defective.

  7. #7
    Join Date
    Apr 2009
    Location
    Deerfield Beach, FL, which is a northern suburb of Fort Lauderdale.
    Posts
    22
    The 'Start' winding looks shorted. There should be more Ohms from C-to-S than from C-to-R. The Start winding should be 90-degrees out of phase with the Main winding in order to obtain turning torque and has to have more Ohms in it.

  8. #8
    Join Date
    Feb 2008
    Location
    California
    Posts
    2,066
    Sounds like the only thing wrong with your compressor is it doesn't have voltage.

  9. #9
    Join Date
    Jul 2010
    Location
    So-Cal
    Posts
    580
    Quote Originally Posted by Phase Loss View Post
    Sounds like the only thing wrong with your compressor is it doesn't have voltage.
    Check your temp control!

  10. #10
    Join Date
    Apr 2009
    Location
    Deerfield Beach, FL, which is a northern suburb of Fort Lauderdale.
    Posts
    22
    Belt slipping on my comprehension level there, I apologize. I mis-read your Ohm-meter readings.

  11. #11
    Join Date
    Jan 2010
    Posts
    6,300
    I've heard it said here " when in doubt jump it out "

  12. #12
    Join Date
    Jun 2010
    Location
    West Palm Beach
    Posts
    10
    The troubleshooting of this refrigerator was unplanned last night and it was kind of late so I didn't have time to troubleshoot more systematically, but I will possibly revisit this case during the week and also get the model number to provide it (I know it is a top-freezer Frigidaire refrigerator) I will trace the voltage to find out which component is cutting it out and hopefully the compressor will work once such component gets jumped out - -- will let you know the outcomes soon.

  13. #13
    Join Date
    Jun 2010
    Location
    West Palm Beach
    Posts
    10
    VTP99: I've heard a similar phrase " When in doubt, amp it out! "

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event