Results 1 to 4 of 4
  1. #1
    Join Date
    Apr 2012
    Location
    ohio
    Posts
    3

    Ruud inducer and blower starts but no ignition

    i have a ruud gas furnace M#UGTA-10EZAJS. On startup both blower and inducer motor runs, but after so long no ignition happens gas valve doesn't energize and open and hot surface ignitor doesn't energize. I know the air handler blower should not be starting just yet. gas valve or hot surface ignitor is not getting proper voltage. I also notice a small crack in the hose from the negative pressure control to the inducer motor. I don't know if im over looking something or what?
    Any answer or tips would be greatly appreciated. thanks.

  2. #2
    Join Date
    Aug 2006
    Location
    Columbus Ohio
    Posts
    1,977
    Get your post count up, show your credentials, and apply for membership.

    This is not a DIY site and we don't talk shop with non pro members.

    If you are not a service tech, hire one.
    UA LU189

    10mm, because it's better than .45acp

  3. #3
    Join Date
    Mar 2007
    Location
    NW AR
    Posts
    2,475
    Easy fix for a pro. You would be money ahead to call one.

  4. #4
    Join Date
    Dec 2004
    Location
    Chicago area
    Posts
    1,438

    Sound like a temp limit

    Replace your air filter, and call for service.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event