Results 1 to 5 of 5

Hybrid View

  1. #1

    Fill valve not energizing

    Manitowic q454. The fill valve is not energizing. It just keeps filling with water. The sensor works, light comes on and goes off with level. Any ideas?

  2. #2
    Join Date
    Feb 2010
    Location
    NE Alabama
    Posts
    301
    So, on this system the fill valve energizing means it opens on power applied, or it's normally closed. If it is filling all the time it has shorted open or has trash in it or aq hole in the diapharm and is leaking by

  3. #3
    Join Date
    Sep 2011
    Location
    Fayetteville, NC
    Posts
    131
    Quote Originally Posted by crymtide View Post
    So, on this system the fill valve energizing means it opens on power applied, or it's normally closed. If it is filling all the time it has shorted open or has trash in it or aq hole in the diapharm and is leaking by
    ditto

  4. #4
    Normally open. Closes on power applied. Bench tested solenoid. It works.

  5. #5
    OK. I got it. It's the fill valve. When I bench tested, I couldn't blow air through it. Watching start up voltage I can see it supposed to open on voltage applied. When 120 drops out it still flows water. Thanks for brainstorming with me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event