Results 1 to 3 of 3
  1. #1

    another liebert humidity problem

    *have gone through past threads with some helpful insight gained, but have not found "the" answer yet.

    Liebert seems to be not much help on this with their answer being to adjust hot gas bypass (unit has new tank "the correct volt tank", new board etc.. all amps good and so forth...ductwork good, not too much if any outside air, plenums tight and are on supply and return to space etc...

    Room is an MRI sealed room with doors only open to allow patients in and out...occasionally.

    I can watch the t-stat read humidity going from 14% (alarm goes off at 15%) to 36% (the setting is 48%) and back down in the span of 15-20 minutes....sometimes less!

    This is a relatively new (3 years, new tank and board) split unit (sorry, no model yet....about a 4-5 ton?

    Having same problems in another MRI Equipment room across town (just a server and the MRI outside unit.

    I can't keep the fan on "high/med" it will ramp up but soon goes back to low/med" (only has 2 speeds, not sure of actual word used)

    This space is sealed. It has no other supplies from rooftops etc...

    Is this a case of adding another humidifier? I wouldn't think so, though I suspect the unit may be slightly oversized for space (though the engineer didn't think so...it was "to spec")

    Kinda baffled, I'm going in to take real psychro readings tomorrow to see if t-stat or sensor is correct.

    ANy suggestions on what to look for when there? Thanks much....it seems my old industrial tranes did a much better job towards this kind of thing...but then again I could work on them in my sleep!

  2. #2
    Join Date
    Aug 2002
    Location
    Sacramento area
    Posts
    69

    Cool

    I see you posted your question almost two months ago but received no responses. Have you solved the problem yet?

    What model is the equipment?

    Does the controller allow you to set the humidity control method? If so, the "Absolute" method could cause what you are seeing. Change it to "Relative".

    Do you have short circuiting of air, with some of the supply air being sucked back into the return, or across the temp/humidity sensor? This also would cause the problem you described.

    You mentioned the space is sealed. Since you are controlling humidity, or attempting to, do you have a vapor seal installed? If not, then the problem is similar to trying to control temperature in a space with no insulation.
    I'm still learning this trade.

  3. #3
    Join Date
    Jun 2002
    Location
    Dacula, GA
    Posts
    12,585
    Pardon my French but I say screw Liebert. If you have a low humidity problem I would have a steam humidifier installed in your supply air with a local thermidistat. Should have gotten just a straight AC or HP with a steam humidifier and saved thousands of bucks plus had a better system. They are over priced in my opinion. Thank you very much
    "I could have ended the war in a month. I could have made North Vietnam look like a mud puddle."
    "I have little interest in streamlining government or in making it more efficient, for I mean to reduce its size. I do not undertake to promote welfare, for I propose to extend freedom. My aim is not to pass laws, but to repeal them. It is not to inaugurate new programs, but to cancel old ones that do violence to the Constitution."
    Barry Goldwater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event