Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2012
    Posts
    1
    Post Likes

    Ice-o-matic 400 stuck in harvest?

    I have a ICE0400HW2 that was working fine last year. I went to start it up after winterizing it and now its stuck in harvest and purges the water for 4 seconds then runs for a few seconds then purges again. Im assuming that it has a low charge or theres an issue with the timer initiate control. Any help would be greatly appreciated. Thanks.

  2. #2
    Join Date
    Dec 2003
    Location
    Citrus County, Florida
    Posts
    1,834
    Post Likes
    have you put gauges on it yet? There is lots of info available.
    Doug

  3. #3
    Join Date
    Dec 2010
    Location
    Woodbridge Twp, NJ
    Posts
    1,309
    Post Likes
    Call in a pro.
    Every customer you take for granted today will be someone else's tomorrow.

  4. #4
    Join Date
    Jun 2009
    Posts
    3
    Post Likes

    Help is available.

    Quote Originally Posted by JoeyB1118 View Post
    I have a ICE0400HW2 that was working fine last year. I went to start it up after winterizing it and now its stuck in harvest and purges the water for 4 seconds then runs for a few seconds then purges again. Im assuming that it has a low charge or theres an issue with the timer initiate control. Any help would be greatly appreciated. Thanks.
    I am a Field Service Manager for Ice-O-Matic. Please give our Tech Line a call at 888-349-4423. We look forward to assisting you.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Related Forums

Plumbing Talks | Contractor MagazineThe place where Electrical professionals meet.
Quality Home Comfort Awards