I was mistaken about the ucp2 not being supported ,i meant the ucp1.Thanks