Oil return questions - Page 2
Page 2 of 2 FirstFirst 12
Results 14 to 16 of 16
  1. #14
    Join Date
    Dec 2010
    Location
    Central US
    Posts
    410
    Quote Originally Posted by jpsmith1cm View Post
    The Henry helicals are pretty good separators.

    Does it have a flange on the bottom of it?

    If so, you may want to pump it down and pull that float plate and clean or replace it. They get junk in them and stop up.
    check to see if it has bolts on top as well, if so there is a filter in it. (take a pic and post)

  2. #15
    Join Date
    May 2008
    Location
    CO
    Posts
    14
    I know there was a bottom flange that could be removed. I don't believe there was any bolts on the top.

    They shut the system down at the end of April and will probably have some time to get into it and check things out.
    Quote Originally Posted by emcontrols View Post
    check to see if it has bolts on top as well, if so there is a filter in it. (take a pic and post)

  3. #16
    Join Date
    Sep 2008
    Location
    Western PA
    Posts
    25,335
    Quote Originally Posted by emcontrols View Post
    check to see if it has bolts on top as well, if so there is a filter in it. (take a pic and post)
    That Henry separator does not have a filter in it. I'm quite familiar with it.



    When you've got it open, there is a screen up inside it. Pull it out and clean it, too. Also, make sure to install the Pre-charge.

    I attached Henry's Oil Control Booklet. Good info.
    Attached Files Attached Files

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event