Results 1 to 8 of 8
  1. #1
    Join Date
    Feb 2012
    Location
    Kansas
    Posts
    9

    19dr carrier diffuser wall question

    Finished doing a leak repair on a 19dr chiller w/ dm compressors, 1000 ton two compressors same circuit. The issue that I am having is the diffuser wall will not operate when chiller is on. Ran chiller through test mode all parameters are ok diffuser wall operates in both directions feedback pots are normal also. Have also swapped the IO board with the chiller next to this one didnot change anything. I am half tempted to swap the main processor board on this chiller also. Just kind of puzzled as to why diffuser wall operates in test mode and not while chiller is running.Any feedback is much apprecited

  2. #2
    Join Date
    Oct 2011
    Location
    La.
    Posts
    284
    Is the unit surging, or giving any problems?

  3. #3
    Join Date
    Apr 2007
    Posts
    177
    Quote Originally Posted by pipefittermarks View Post
    Finished doing a leak repair on a 19dr chiller w/ dm compressors, 1000 ton two compressors same circuit. The issue that I am having is the diffuser wall will not operate when chiller is on. Ran chiller through test mode all parameters are ok diffuser wall operates in both directions feedback pots are normal also. Have also swapped the IO board with the chiller next to this one didnot change anything. I am half tempted to swap the main processor board on this chiller also. Just kind of puzzled as to why diffuser wall operates in test mode and not while chiller is running.Any feedback is much apprecited
    More than likely the diffuser wall needs to be rebuilt the cylinder is leaking thru at the orings and it should be removed and sent to the Carrier repair shop in texas. I guess I should ask the question first was it working before you did the leak repair? what is your oil pressure? since it uses oil to move the wall.

  4. #4
    Join Date
    Feb 2003
    Location
    Wichita Ks
    Posts
    1,507
    since the wall seems to move ok and the feedback is reading normal as you say. verify all temperature sensor and make sure they read right. the charge needs to be close and checked the condeser tubes they need to be clean. these units are a headache.

  5. #5
    Join Date
    Feb 2012
    Location
    Kansas
    Posts
    9
    We finally got the bottom of this awhile back and I forgot to check in, we had an issue with the potentiometer that is in the motor run vac signal back at the chiller. We had to find an outfit to troubleshoot the ct in the starter it cam back ok we narrowed it down to the potentiometer and tweaked it @ FLA to get the .5vac back to chiller control board the diuffuser wall would then function. Counting down the days till they chop those machines up...I just might volunteer to run a blue wrench on the construction crew.

  6. #6
    Join Date
    Jan 2005
    Posts
    605
    A gas axe does well on those, but I wouldn't want to breath the fumes. Hahaha

  7. #7
    Join Date
    Aug 2011
    Location
    Chicago
    Posts
    51
    Moved wall all the way open then dip swicth MP so it thinks its a DK compressor

  8. #8
    Join Date
    Mar 2011
    Posts
    260
    You know what the DM stands for in 19DM? Damned Mistake!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event