Search Results - HVAC-Talk: Heating, Air & Refrigeration Discussion

Search:

Type: Posts; User: JoshuaHackler

Search: Search took 0.00 seconds.

  1. Oh, and the pilot light stays lit and burns...

    Oh, and the pilot light stays lit and burns strong blue.
  2. I've been informed via another forum that my...

    I've been informed via another forum that my furnace may not have a flame sensor, and that the problem could be a thermocouple. Would a faulty thermocouple cause these symptoms?
  3. Thanks for the reply. So, the flame sensor is...

    Thanks for the reply. So, the flame sensor is likely included in another part? At this point I just want to know where it is. I'm calling a pro tomorrow to come take a look.
  4. I'm getting to that point. It's just that a dirty...

    I'm getting to that point. It's just that a dirty flame sensor is such an easy fix, I want to do everything I can to locate it before calling my HVAC guy out. But, on this particular furnace, it...
  5. That's the problem. I can't find a manual for the...

    That's the problem. I can't find a manual for the unit online, and there wasn't one left behind by the previous owner. Thanks for the suggestions, I'll try to locate some ignitor specs.

    Josh
  6. I wasn't looking for DIY advice, just wondering...

    I wasn't looking for DIY advice, just wondering if someone knew where the flame sensor was on this model furnace.
  7. Coleman Evcon Model AGU07512A flame sensor?

    My furnace keeps turning on and shutting off after about 10-15 seconds. I'm fairly certain the problem would be a dirty flame sensor, but I cannot for the life of me locate it on this model. Does...
Results 1 to 7 of 7
Comfortech Show Promo Image

Related Forums

Plumbing Talks | Contractor Magazine
Forums | Electrical Construction & Maintenance (EC&M) Magazine
Comfortech365 Virtual Event